POJ 1328 Radar Installation

                                                Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
题意:给定坐标系上N个点的坐标,你可以画半径为d的圆,求出画最少的圆使得所有点都在圆内的圆的个数。
题解:通过转换题意,求一个点为圆心,半径为D的圆与X轴的交点,那么得到一条线段,线段上的所有点为圆心都满足题意,那么就转换成了给定N段区间,求最少多少个点能连接所有区间。(需要double)

AC代码:

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define _for(i,a,b) for(int i=a;i<=b;i++)
const int maxn = 1007;
struct node
{
	double x,y;
}a[maxn];
bool cmp(node p,node q)
{
	return p.y<q.y;
}
int n,m,vis[maxn];
int main(int argc, char const *argv[])
{
	int t = 0;
	while(cin>>n>>m)
	{
		t++;
		if(n==0&&m==0)break;
		int ok = 1;
		_for(i,1,n)
		{
			vis[i]=0;
			double x,y;
			cin>>x>>y;
			if(y>m)ok = 0;
			double l = sqrt(1.0*m*m-y*y);
			a[i].x=x-l;
			a[i].y=x+l;
		}
		if(ok==0)cout<<"Case "<<t<<": -1"<<endl;
		else
		{
			sort(a+1,a+1+n,cmp);
			int now = 1;
			int ans = 0;
			_for(i,1,n)
			{
				if(vis[i])continue;
				vis[i]=1;
				for(int j=i+1;j<=n;j++)
				{
					if(a[j].x<=a[i].y)
					{
						vis[j]=1;
					}
				}
				ans++;
			}
			cout<<"Case "<<t<<": "<<ans<<endl;
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值