1003. Emergency (25)

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
题意:
给你一个图,图中每条边有不同的长度值,以及各个顶点的权值。现有一个出发点和一个目的地,让你求出从出发点到目的地的最短距离路径的走法有多少种,顺便求出在这些最短路径中哪条路径经过的顶点权值最大,输出这个权值。
很容易的想到这种单源最短路的问题用迪杰斯特拉算法,里面会用到 priority_queue(),该函数的用法请自行百度。
也可以用DFS很快的实现(本宝宝第一次用这种的DFS是求N个数的全排列问题,那时还不知有next_permutation()函数),下面的代码是用深搜实现的。

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <climits>
using namespace std;

typedef long long ll;

int N,M,C1,C2;
int a[505];
int vis[505];
int G[505][505];
int count_num = 0,max_team = 0;
int min_dis = INT_MAX;


void DFS(int sur,int des,int dis,int team){
	
	if( dis>min_dis )
	 return ;
	if( sur==des ){
		if( min_dis>dis ){
			min_dis = dis;
			count_num = 1;
			max_team = team;
		}
		else if( min_dis==dis ){
			count_num++;
			max_team = max(team,max_team);
		}
		return ;
	}
	for(int i=0; i<N; i++)
		if( G[sur][i]!=-1&&!vis[i] ){
			vis[i] = 1;
			DFS(i,des,dis+G[sur][i],team+a[i]);
			vis[i] = 0;
		}	
}

int main(){
	
	for(int i=0; i<=500; i++)
		for(int j=0; j<=500; j++){
			G[i][j] = -1;
			G[j][i] = -1;
		}
	scanf("%d %d %d %d",&N,&M,&C1,&C2);
	for(int i=0; i<N; i++)
		scanf("%d",&a[i]);
	int c1,c2,len;
	for(int i=1; i<=M; i++){
		scanf("%d %d %d",&c1,&c2,&len);
		G[c1][c2] = len;
		G[c2][c1] = len;
	}
	
	DFS(C1,C2,0,a[C1]);
	cout << count_num << " " << max_team << endl;
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值