Ubuntu 64位系统安装交叉编译环境一直提醒 没有那个文件或目录

安装交叉编译环境搞了一个晚上

一直提示

root@zqs-pc:~# arm-linux-gcc
/usr/local/arm/4.3.2/bin/arm-linux-gcc: 行 3: /usr/local/arm/4.3.2/bin/arm-none-linux-gnueabi-gcc: 没有那个文件或目录


刚开始一直认为是环境变量的问题

添加环境变量:

vim /etc/profile

    export PATH=/usr/local/arm/4.3.2/bin:$PATH
    export TOOLCHAIN=/usr/local/arm/4.3.2
    export TB_CC_PREFIX=arm-linux-
    export PKG_CONFIG_PREFIX=$TOOLCHAIN/arm-none-linux-gnueabi

接下来:

       source /etc/profile


问题依旧,结果怎么搞都不行


直接cd /usr/local/arm/4.3.2/bin

运行./arm-none-linux-gnueabi-gcc

同样不行,这么说肯定不是环境问题了,而是arm-none-linux-gnueabi-gcc无法运行,

问度娘得知是64位系统的问题,64位系统需要安装32位运行库


sudo apt-get install ia32-libs

结果

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
E: 未发现软件包 ia32-lib32z1
zqs@zqs-pc:/usr/local/arm/4.3.2/bin$ sudo apt-get install ia32-libs
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
现在没有可用的软件包 ia32-libs,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
可是下列软件包取代了它:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: 软件包 ia32-libs 没有可供安装的候选者


a32-libs 装不上。。

网上一搜~方法一堆~


解决方法:

方法一:

sudo apt-get install lib32z1

方法二:

sudo apt-get install g++-multilib

方法三:

$ sudo dpkg --add-architecture i386
$ sudo apt-get update
$ sudo apt-get install ia32-libs

选其一,搞掂~~






发布了4 篇原创文章 · 获赞 1 · 访问量 9209
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览