[ACM] HDU 5131 Song Jiang's rank list (模拟)

Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 36    Accepted Submission(s): 18


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 


 

Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
 


 

Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed.

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 


 

Sample Input
  
  
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
 


 

Sample Output
  
  
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
 


 

Source

 

解题思路:

题意为给N个英雄,每个英雄有自己的名字和杀敌人的个数,现在给这些英雄排名,首先按杀敌人的个数多少排名,杀敌人越多,排名越靠前,如果杀敌人个数相同,那么名字字母序小的排名靠前。给定n个英雄的名字和杀敌人的个数,首先按排名输出英雄的名字以及杀敌人个数,然后有q个询问,每个询问包括一个英雄的名字,然后输出该英雄的主排名和次排名,主排名意思是比该英雄杀敌人个数多的英雄个数+1,次排名意思是和该英雄杀敌人个数相同但排名比他靠前的英雄个数+1,如果次排名是1的话,只输出主排名,否则两者都输出。

给结构体排序,然后用map记录下英雄名字以及杀敌人个数,然后线性在结构体数组里面查找就可以了。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <cmath>
#include <iomanip>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <cctype>
using namespace std;
#define ll long long
const int maxn=202;

struct P
{
    string name;
    int k;
}p[maxn];

bool cmp(P a,P b)
{
    if(a.k>b.k)
        return true;
    else if(a.k==b.k)
    {
        if(a.name<b.name)
            return true;
        return false;
    }
    return false;
}
int n;
map<string,int>mp;

void find(string str)
{
    int major=1;
    int minor=1;
    for(int i=1;i<=n;i++)
    {
        if(p[i].name==str)
        {
            break;
        }
        if(p[i].k>mp[str])
            major++;
        if(p[i].k==mp[str])
            minor++;
    }
    cout<<major;
    if(minor!=1)
        cout<<" "<<minor<<endl;
    else
        cout<<endl;
}

int main()
{
    while(cin>>n&&n)
    {
        mp.clear();
        for(int i=1;i<=n;i++)
            cin>>p[i].name>>p[i].k;
        sort(p+1,p+1+n,cmp);
        for(int i=1;i<=n;i++)
        {
            cout<<p[i].name<<" "<<p[i].k<<endl;
            mp[p[i].name]=p[i].k;
        }
        int q;
        string str;
        cin>>q;
        while(q--)
        {
            cin>>str;
            find(str);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值