[ACM]Common Subsequence

286 篇文章 140 订阅
150 篇文章 0 订阅
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 


 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 


 

Sample Output
  
  
4 2 0

 

解题思路:

横竖两轴分别为两字符串中的字符,其中里面的数字均是0,代码中有体现。然后从左上角填数字,对应位置如果有相同的字符,则本位置的数字等于相邻左上角的数字加1;

即当 s1[i]== s2 [j]  时, a[i][j]= a[i-1][j-1]+1  ,对应位置如果没有相同的字符,本位置的数字等于相邻左,上位置数字的最大值,即s1[i] != s2[j]时, a[i][j]= max(a[i-1] [j], a[i]  [j-1]),一直计算到,a[s1.length()] [ s2.length()] 位置,即为答案。

辅助图:

代码:

#include <iostream>
#include <string>
#define max 1000
using namespace std;
int a[max][max];
int max1(int x,int y)
{
    int m;
    m=x>y?x:y;
    return m;
}//返回两个数最大值的函数
int main()
{

    string s1,s2;
    while(cin>>s1>>s2)
    {
        int i,j;
        for(i=0;i<=s1.length();i++)
            a[i][0]=0;
        for(i=0;i<=s2.length();i++)
            a[0][i]=0;//a数组上边左边数据初始化为0
        for(i=1;i<=s1.length();i++)
            for(j=1;j<=s2.length();j++)
        {
            if(s1[i-1]==s2[j-1])
                a[i][j]=a[i-1][j-1]+1;
            else
                a[i][j]=max1(a[i-1][j],a[i][j-1]);
        }
        cout<<a[s1.length()][s2.length()]<<endl;
    }
}


 

运行截图:

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值