STL的应用

//## set的应用

G - 不重复数字 HYSBZ - 2761

给出N个数,要求把其中重复的去掉,只保留第一次出现的数。
例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4。

Input
输入第一行为正整数T,表示有T组数据。
接下来每组数据包括两行,第一行为正整数N,表示有N个数。第二行为要去重的N个正整数。

Output

对于每组数据,输出一行,为去重后剩下的数字,数字之间用一个空格隔开。
Sample Input
2
11
1 2 18 3 3 19 2 3 6 5 4
6
1 2 3 4 5 6
Sample Output
1 2 18 3 19 6 5 4
1 2 3 4 5 6
Hint
对于30%的数据,1 <= N <= 100,给出的数不大于100,均为非负整数;

对于50%的数据,1 <= N <= 10000,给出的数不大于10000,均为非负整数;

对于100%的数据,1 <= N <= 50000,给出的数在32位有符号整数范围内。

提示:

由于数据量很大,使用C++的同学请使用scanf和printf来进行输入输出操作,以免浪费不必要的时间。

第一种是用STL中的set解决的
用的是set中的迭代器和find()函数 和end()函数

#include <bits/stdc++.h>
using namespace std;
set<int>st;
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0); 
	int t,n,a;
	cin>>t;
	while(t--)
	{
		st.clear();
		int num = 0;
		scanf("%d",&n);
		while(n--) 
		{
			scanf("%d",&a);
			set<int>::iterator iter=st.find(a); //st.find()::返回一个指向查找元素的迭代器,如果没有找到就返回st.end()
			//st.end()返回最后一个元素之后的迭代器,不是最后一个元素	
			if(iter == st.end())
			{
				st.insert(a);
				if(num++!=0)
					cout<<" "<<a;
				else
					cout<<a;	
			} 	
		}		
		cout<<endl;
	}
	return 0;
}

第二种方法是用常用思维解决的

#include<bits/stdc++.h>

using namespace std;
const int maxn = 1e6+10;
int a[maxn];
int num;
bool find(int v)
{
	int i;
	for(int i=1;i<num;i++)
	{
		if(v==a[i])
			return 0;
	}
	return 1;
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	int t,n,v;
	cin>>t;
	while(t--)
	{
		cin>>n;
		num=1;
		while(n--)
		{
			cin>>v;
			if(find(v))//判断是否在前面构建的数组中有v 
			{
				a[num++]=v;
			}
		}
		for(int i=1;i<num;i++)
		{
			if(i!=num-1)
				cout<<a[i]<<" ";
			else
				cout<<a[i]<<endl;	
		}
	}
	return 0;
 }

第二种方法输出地方的简化

#include<bits/stdc++.h>

using namespace std;
const int maxn = 1e6+10;
int a[maxn];
int num;
bool find(int v)
{
	int i;
	for(int i=1;i<num;i++)
		if(v==a[i])
			return 0;
	return 1;
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	int t,n,v;
	cin>>t;
	while(t--)
	{
		cin>>n;
		num=1;
		int outnum=0; 
		while(n--)
		{
			cin>>v;
			if(find(v))
			{
				a[num++]=v;
				if(outnum++!=0)
					cout<<" "<<v;
				else
					cout<<v;
			}
		}
		cout<<endl;
	}
	return 0;
 }

map的应用

**F - Let the Balloon Rise HDU - 1004 **
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

#include<bits/stdc++.h>

using namespace std;
map<string,int>mp;

int main()
{
	int n;
	string s;
	while(cin>>n&&n)
	{
		mp.clear();
		int maxn = 0;
		for(int i=1;i<=n;i++)
		{
			cin>>s;
			mp[s]++;
		}
		string str;
		map<string,int>::iterator iter;
		for(iter=mp.begin();iter!=mp.end();iter++)
		{
			if(iter->second>=maxn)
			{
				maxn=iter->second;
				str=iter->first;
			} 
		}
		cout<<str<<endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值