KMP算法和hash算法

poj3461 运用KMP算法和hash算法解答

Oulipo

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

一、哈希算法

#include<bits/stdc++.h>

using namespace std;
const int maxn = 1e6+10;
char s[maxn],str[maxn];
typedef unsigned long long ull;
ull hashes[maxn];
const ull mod = 1e9+9;
const ull base = 2333;//ull base = 233;
ull p[maxn];
ull gethashes(int l,int r)
{
	return (hashes[r]-hashes[l-1]*p[r-l+1]%mod+mod)%mod;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s %s",str+1,s+1);
		int m=strlen(str+1);
		int n=strlen(s+1);
		p[0]=1;	
		for(int i=1;i<=n;i++)
		{
			hashes[i]=(hashes[i-1]*base%mod+s[i])%mod;
			p[i]=(p[i-1]*base)%mod;
		}
		ull ans = 0;
		for(int i=1;i<=m;i++)
			ans = (ans*base%mod+str[i])%mod;	
		int res=0;	
		for(int i=m;i<=n;i++)
		{
			if(gethashes(i-m+1,i)==ans)
				res++;
		}
		printf("%d\n",res);
	}
	return 0;
 } 

二、KMP算法

#include<bits/stdc++.h>

using namespace std;
string s,str;
vector<int>mal_nxt(string s)
{
	int len = s.size();
	vector<int>nxt(len);
	for(int i=1;i<len;i++)
	{
		int j=nxt[i-1];
		while(s[i]!=s[j]&&j>0)
			j=nxt[j-1];
		if(s[i]==s[j])
			j++;
		nxt[i]=j;		
	}
	return nxt;
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cout.tie(0);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>str>>s;
		int n=s.length();
		int m=str.length();
		string st=str+'#'+s;
		int len=st.size();
		vector<int>nxt=mal_nxt(st);
		int res=0;
		for(int i=m+1;i<len;i++)
		{
			if(nxt[i]==m)
				res++;
		}	
		cout<<res<<endl;
	}	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值