蓝桥杯练习【STL训练】——Ignatius and the Princess IV

题目描述:

"OK, you are not too bad, em... But you can never pass the next 
test." feng5166 says."I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says."But what is the characteristic of the special integer?" Ignatius asks.        
"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.
Can you find the special integer for Ignatius?

输入:

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero.  The second line contains the N integers. The input is terminated by the end of file.

输出:

For each test case, you have to output only one line which contains 
the special number you have found.

样例输入:

5 
1 3 2 3 3 
11 
1 1 1 1 1 5 5 5 5 5 5 
7 
1 1 1 1 1 1 

样例输出:

3
5
1

解题思路:

此题主要是找出出现次数大于(N+1)/2的数然后输出即可。用一个数组a来保存每个数出现的次数,若符合要求则直接输出该数。

参考代码:

#include<bits/stdc++.h>
using namespace std;

int a[1000000];

int main()
{
    int N,num,i;
    int index=0;
    while(scanf("%d",&N)!=EOF){
        memset(a,0,sizeof(a));//清空数组
        int temp=(N+ 1)/2;
        while(N--){
            scanf("%d",&num);
            a[num]++;
            if(a[num]>=temp){
                index=num;
            }
        }
        printf("%d\n",index);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值