1020 Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2

分析:由后序和前序,输出层次遍历序列。

参考代码:

#include<iostream>
#include<vector>
#include<queue>
#define MAX 40
using namespace std;
int post[MAX], in[MAX];

typedef struct node * BiTree;
struct node 
{
    int data;
    BiTree left;
    BiTree right;
};
BiTree buildTree(int postStart,int postEnd,int inStart,int inEnd)
{
    BiTree root = (struct node *)malloc(sizeof(struct node));
    root->data = post[postEnd];
    int i, leftNum, rightNum;
    for (i = inStart; i <= inEnd; i++)
    {
        if (in[i] == post[postEnd])
        {
            leftNum = i - inStart;
            rightNum = inEnd - i;
            break;
        }
    }
    if (leftNum)
        root->left = buildTree(postStart, postStart + leftNum - 1, inStart, i - 1);
    else root->left = NULL;
    if (rightNum)
        root->right = buildTree(postEnd - rightNum, postEnd - 1, i + 1, inEnd);
    else root->right = NULL;
    return root;
}
int main()
{
    int n, cnt = 0;
    queue<struct node*>q;
    struct node * treeNode=NULL;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> post[i];
    }
    for (int i = 0; i < n; i++)
    {
        cin >> in[i];
    }
    BiTree Tree = buildTree(0, n - 1, 0, n - 1);
    q.push(Tree);
    while (!q.empty())
    {
        treeNode = q.front();
        if (cnt != 0)
            cout << " ";
        cout << treeNode->data;
        ++cnt;
        q.pop();
        if (treeNode->left)
            q.push(treeNode->left);
        if (treeNode->right)
            q.push(treeNode->right);
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值