Centos8部署docker详细流程

一、卸载旧版本

dnf remove docker \
                  docker-client \
                  docker-client-latest \
                  docker-common \
                  docker-latest \
                  docker-latest-logrotate \
                  docker-logrotate \
                  docker-engine

二、安装依赖包

安装所需的软件包。yum-utils 提供了 yum-config-manager ,并且 device mapper 存储驱动程序需要 device-mapper-persistent-data 和 lvm2。

  dnf install -y yum-utils \
  device-mapper-persistent-data \
  lvm2

三、如何添加必要的Docker存储库

我们将使用dnf config-manager实用程序添加Docker存储库。
注意:一定要用阿里yum源,官方yum源会报错且下载速度慢

dnf config-manager --add-repo=https://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo

四、如何找到Docker CE的可安装版本

截至目前,Red Hat已阻止docker-ce的安装,因此,如果您尝试运行命令sudo dnf install docker-ce,将运行失败。相反,您必须安装特定版本的Docker。要找出可用的版本,请发出以下命令:

dnf list docker-ce --showduplicates | sort -r

从该列表中,我们可以看到版本docker-ce-3:18.09.1-3.el7可用于安装。

五、如何安装Docker CE

1、安装containerd.io

dnf install -y containerd.io

2、安装指定较低版本的docker-ce(docker-ce自带docker-ce-cli):

dnf install docker-ce-3:18.09.1-3.el7

因为yum仓库的最高版本containerd.io无法依赖docker,需要更高版本的containerd.io,所以需要安装指定docker-ce更低版本,会报错:
版本太低

六、查看版本信息

docker --version

七、启动

systemctl start docker
systemctl enable docker
发布了3 篇原创文章 · 获赞 0 · 访问量 39
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 游动-白 设计师: 上身试试

分享到微信朋友圈

×

扫一扫,手机浏览