Cocoapods的详细使用教程 (安装/使用/删除/注意)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/st646889325/article/details/53501335

什么是CocoaPods

CocoaPods是OS X和iOS下的一个第三类库管理工具,通过CocoaPods工具我们可以为项目添加被称为“Pods”的依赖库(这些类库必须是CocoaPods本身所支持的),并且可以轻松管理其版本。 
Cocoapods意义体现在两个方面。第一,在引入第三方库时它可以自动为我们完成各种各样的配置,包括配置编译阶段、连接器选项、甚至是ARC环境下的-fno-objc-arc配置等。第二,使用CocoaPods可以很方便地查找新的第三方库,这些类库是比较“标准的”,而不是网上随便找到的,这样可以让我们找到真正好用的类库。 
接下来我们将介绍CocoaPods的使用。

CocoaPods的核心组件

CocoaPods是用Ruby写的,并划分成了若干个Gem包。 
CocoaPods在解析执行过程中最重要的几个包的路径分别是:CocoaPods/CocoaPods、 CocoaPods/Core 和 CocoaPods/Xcodeproj。  
CocoaPods/CocoaPod:这是面向用户的组件,每当执行一个pod命令时,这个组件将被激活。它包括了所有实用CocoaPods的功能,并且还能调用其他gem包来执行任务。  
CocoaPods / Core:Core gem提供了与CocoaPods相关的文件(主要是podfile和podspecs)的处理。  
Podfile:该文件用于配置项目所需要的第三方库,它可以被高度定制。本文中我们主要在这里做动作。 
Podspec:该文件描述了一个库将怎样被添加进工程中。.podspec文件可以标识该第三方库所需要的源码文件、依赖库、编译选项,以及其他第三方库需要的配置。  
CocoaPods / Xcodeproj:这个包负责处理工程文件,它能创建以及修改.xcodeproj文件和.xcworkspace文件。它也可以作为一个独立的包使用,当你要编写修改项目文件的脚本时,可以考虑使用CocoaPods/Xcodeproj。

下载和安装CocoaPods

在安装CocoaPods之前,首先要在本地安装好Ruby环境。至于如何在Mac中安装好Ruby环境,请找度娘和谷哥。 
CocoaPods是用Ruby写的,所以运行需要安装Ruby环境。Mac中已经自带Ruby环境,这个不用我们担心,如果认为Ruby环境不够新,我们可以先更新,打开终端,输入以下命令:

$ gem update --system  
  • 1
  • 1

接下来我们可以安装CocoaPods了

首先在Terminator中输入以下命令:

$ sudo gem install cocoapods
  • 1
  • 1

如果在终端中敲入这个命令之后,可能半天没有任何反应。可能就是被墙了. 所以我们可以用淘宝的Ruby镜像来访问cocoapods。按照下面的顺序在终端中敲入依次敲入命令:

$ gem sources --remove https://rubygems.org/
  • 1
  • 1

等有反应之后再敲入以下命令:

$ gem sources -a http://ruby.taobao.org/
  • 1
  • 1

为了验证你的Ruby镜像是并且仅是taobao,可以用以下命令查看:

$ gem sources -l
  • 1
  • 1

只有在终端中出现下面文字才表明你上面的命令是成功的:

*** CURRENT SOURCES ***
http://ruby.taobao.org/
  • 1
  • 2
  • 1
  • 2

这时候,我们再次在终端中运行:

$ sudo gem install cocoapods
  • 1
  • 1

安装输出非常长,这里就不贴出来了。

然后使用setup命令配置CocoaPods(这个命令也可以不运行,但是第一次使用pod命令时这个setup过程也会自动执行)

$ pod setup  
  • 1
  • 1

Setting up CocoaPods master repo 
Setup completed (read-only access) 

这个时间可能会比较长!!!!!!!有可能等的时间很长。耐心等待下。 
这个时候就完成了 cocoapods 的安装操作了

使用CocoaPods

比如要添加AFNetworking 
AFNetworking在Github中的地址为:https://github.com/AFNetworking/AFNetworking 
这里也说明了如何使用CocoaPods配置该类库. 
这里写图片描述

如何确定CocoaPods是否支持我们想要加入的目标类库?使用Search命令搜索类库名:

$ pod search AFNetworking
  • 1
  • 1

如果CocoaPods支持,将会输出搜索到的所有类库版本和信息,以及在Podfile中配置的写法,例如:

-> AFNetworking (2.1.0)  
   A delightful iOS and OS X networking framework.  
   pod 'AFNetworking', '~> 2.1.0'  
   - Homepage: https://github.com/AFNetworking/AFNetworking  
   - Source:   https://github.com/AFNetworking/AFNetworking.git  
   - Versions: 2.1.0, 2.0.3, 2.0.2, 2.0.1, 2.0.0-RC3, 2.0.0-RC2, 2.0.0-RC1,  
   2.0.0, 1.3.3, 1.3.2, 1.3.1, 1.3.0, 1.2.1, 1.2.0, 1.1.0, 1.0RC3, 1.0RC2,  
   1.0RC1, 1.0.1, 1.0, 0.9.2, 0.9.1, 0.9.0, 0.7.0, 0.5.1, 0.10.1, 0.10.0 [master  
   repo]  
   - Sub specs:  
     - AFNetworking/Serialization (2.1.0)  
     - AFNetworking/Security (2.1.0)  
     - AFNetworking/Reachability (2.1.0)  
     - AFNetworking/NSURLConnection (2.1.0)  
     - AFNetworking/NSURLSession (2.1.0)  
     - AFNetworking/UIKit (2.1.0)  


-> AFNetworking+AutoRetry (0.0.2)  
   Auto Retries for AFNetworking requests  
   pod 'AFNetworking+AutoRetry', '~> 0.0.2'  
   - Homepage: https://github.com/shaioz/AFNetworking-AutoRetry  
   - Source:   https://github.com/shaioz/AFNetworking-AutoRetry.git  
   - Versions: 0.0.2, 0.0.1 [master repo]  


-> AFNetworking-RACExtensions (0.1.2)  
   AFNetworking-RACExtensions is a delightful extension to the AFNetworking  
   classes for iOS and Mac OS X.  
   pod 'AFNetworking-RACExtensions', '~> 0.1.2'  
   - Homepage: https://github.com/CodaFi/AFNetworking-RACExtensions  
   - Source:   https://github.com/CodaFi/AFNetworking-RACExtensions.git  
   - Versions: 0.1.2, 0.1.1, 0.0.1 [master repo]  


-> AFNetworking-ReactiveCocoa (0.0.2)  
   Make AFNetworking reactive.  
   pod 'AFNetworking-ReactiveCocoa', '~> 0.0.2'  
   - Homepage: https://github.com/uasi/AFNetworking-ReactiveCocoa  
   - Source:   https://github.com/uasi/AFNetworking-ReactiveCocoa.git  
   - Versions: 0.0.2, 0.0.1 [master repo]  


-> AFNetworking-Synchronous (0.2.0)  
   Synchronous requests for AFNetworking  
   pod 'AFNetworking-Synchronous', '~> 0.2.0'  
   - Homepage: https://github.com/paulmelnikow/AFNetworking-Synchronous  
   - Source:   https://github.com/paulmelnikow/AFNetworking-Synchronous.git  
   - Versions: 0.2.0, 0.1.0 [master repo]  
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21
  • 22
  • 23
  • 24
  • 25
  • 26
  • 27
  • 28
  • 29
  • 30
  • 31
  • 32
  • 33
  • 34
  • 35
  • 36
  • 37
  • 38
  • 39
  • 40
  • 41
  • 42
  • 43
  • 44
  • 45
  • 46
  • 47
  • 48
  • 49

然后, 在我们的工程目录下创建Podfile文件,该文件用来控制CocoaPods的下载内容,该文件是没有后缀的,每个项目只需要一个Podfile文件,如果需要导入多个类库那么统一在该文件中书写下载内容。 
创建过程:首先cd到工程目录

$ cd 当前工程目录
  • 1
  • 1

然后创建Podfile并且使用vim编写.

$ vim Podfile
  • 1
  • 1

然后进入 vim 编写

platform :ios,'7.0'
target 'LZFoodNews' do
    pod 'SDWebImage'
    pod 'AFNetworking', '~>2.1'  
end

~                                                                                 
~                                                                                 
~                                                                                                                                           
~                                                                                               
~                                                                                 
:wq  
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 11
  • 12

在编辑完成后先按esc,再按“:”,输入wq保存并退出。 
Podfile中的文字的意思是,当前AFNetworking支持的iOS最高版本是iOS 7.0, 要下载的AFNetworking版本是2.1. pod ‘SDWebImage’ 的意思是下载最新版本的. 
也可以用文本编辑工具打开该文件进行编辑,所以, 在创建 Podfile的时候也可以不用在 vim 中编写完整, 可以先创建了, 再进行编辑.  
在这要注意尽量不要使用文本编辑去编辑Podfile,最好使用Xcode编辑,或者使用终端敲命令去编辑, 这样就会避免输入格式错误. 
在有了Podfile后,编辑完成后, 输入以下命令安装类库:

$ pod install
  • 1
  • 1

安装完成后,输出信息如下:

$ pod install  
Analyzing dependencies  
Downloading dependencies  
Installing AFNetworking (2.1.0)  
Installing JSONKit-NoWarning (1.1)  
Installing MBProgressHUD (0.8)  
Generating Pods project  
Integrating client project  

[!] From now on use `CocoaPodsDemo.xcworkspace`.  
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9
  • 10

最后一句表明,如果要正确打开工程我们应该打开最新生成的.xcworkspace文件。

打开工程然后可以看到工程目录发生变化了,类库都安装上了.打开Build Phases和 Build setting,可以看到CocoaPods已经自动为我们完成了所有设置.

正确编译运行一个包含CocoaPods类库的项目

如果一个项目中已经包含了CocoaPods的配置文件,但是编译却出现错误,那么我们仅需要一行命令就可以配置好所有的第三方类库了:

$ pod update  
  • 1
  • 1

pod update 和 pod install 区别在于, install 检查到当前三方库有的话就不会去下载了, 但 update 无论是否在项目中已经存在, 都会重新下载更新的.

注意

当Cocoapods向项目中增加了一个第三方库的时候,不仅仅只是添加代码,由于每个第三方类库有不同的target,所以每次添加第三方库时,都会有几个文件被写入磁盘,包括Podfile.lock和Manifest.lock文件等。 
其中Podfile.lock记录了需要被安装的pod的每个已安装的版本。如果你想知道已安装的pod是哪个版本,可以查看这个文件。 
Manifest.lock是每次运行pod install时创建的Podfile.lock文件的副本。

cocoapods 只需要安装一次, 当前电脑有的时候, 每个工程进行 cocoapods 配置时, 只需要进行下列步骤: 
1.在 pod search 命令后, 需要在终端输入 cd 命令, 你项目所在目录,然后在当前目录下,利用vim创建Podfile .每个项目 podfile 文件生成一次就够了,  
2.接下来就是第三方的下载和使用了, 可以打开终端通过 vim 来输入命令或者直接打开 podfile 文件在文本中编辑 ,然后在终端 pod install 下载就可以了

删除项目中已经配置的类库

1.在已经配好的CocoaPods打开Podfile文件 
2.删除要移除的第三方库 
3.打开终端 cd 到当前项目目录下,重新执行pod install命令。 
成功后会输出包含下面信息:

Removing #要移除的三方库#  
Generating Pods project  
Integrating client project  
sending stats
  • 1
  • 2
  • 3
  • 4
  • 1
  • 2
  • 3
  • 4

在项目中移除CocoaPods

如果你觉得CocoaPods让你的项目出现了问题,不好用甚至是恶心,想将其从项目中彻底移除,也有方法:

1.删除工程文件夹下的Podfile、Podfile.lock和Pods文件夹。 
2.删除xcworkspace文件。 
3.打开xcodeproj文件,删除项目中的Pods文件夹及Pods.xcconfig引用和libpods.a: 
4.打开Build Phases选项,删除Check Pods Manifest.lock和Copy Pods Resources,以及Embeded Pods Frameworks. 
这里写图片描述
5.完成,编译运行,无错通过。

从项目中移除某个类库直接修改” Podfile “文件即可,但是移除整个CocoaPods就有点麻烦了,或许有其他方法。

另外,如果在编辑工程时不小心删除了某个文件,如Podfile.lock,那么我们就要用上面的方法先移除整个CocoaPods,然后重新建立Podfile和使用pod install命令重装CocoaPods。

阅读更多
换一批

没有更多推荐了,返回首页