PAT:1013 Battle Over Cities (25分)(DFS)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

​​​​

对于图来讲,如果DFS后没有让状态全部改变,那么就说明有地方时不连通的,所以至少得建一个桥,建完之后再DFS,如果还不能让全部状态改变,说明还得建桥,这样等到全部状态都改变了,也说明桥建完了 

#include<bits/stdc++.h>
using namespace std;
vector<vector<int>>v;
bool visit[10010]={false};
void dfs(int index)
{
    visit[index]=true;
    for(int i=0;i<v[index].size();i++){
        if(visit[v[index][i]]==false)
            dfs(v[index][i]);
    }
}

int main()
{
    int n,m,k;
    scanf("%d %d %d",&n,&m,&k);
    v.resize(n+1);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    for(int i=0;i<k;i++){
        fill(visit,visit+10010,false);
        int sum=-1;
        int a;
        scanf("%d",&a);
        visit[a]=true;
        for(int j=1;j<=n;j++){
            if(visit[j]==false)
            {
             dfs(j);
             sum++;
            }
        }
        cout<<sum<<endl;

    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值