数据结构实验之图论七:驴友计划---3363

数据结构实验之图论七:驴友计划

Time Limit: 1000MS   Memory Limit: 65536KB
Problem Description
做为一个资深驴友,小新有一张珍藏的自驾游线路图,图上详细的标注了全国各个城市之间的高速公路距离和公路收费情况,现在请你编写一个程序,找出一条出发地到目的地之间的最短路径,如果有多条路径最短,则输出过路费最少的一条路径。
Input

连续T组数据输入,每组输入数据的第一行给出四个正整数N,M,s,d,其中N(2 <= N <= 500)是城市数目,城市编号从0~N-1,M是城市间高速公路的条数,s是出发地的城市编号,d是目的地的城市编号;随后M行,每行给出一条高速公路的信息,表示城市1、城市2、高速公路长度、收费额,中间以空格间隔,数字均为整数且不超过500,输入数据均保证有解。 

Output

在同一行中输出路径长度和收费总额,数据间用空格间隔。 

Example Input
1
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Example Output
3 40


1.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define inf 0x3f3f3f3f
struct node{
int ct1,ct2,len,cost;
}a[1000];
int dis[1000],dt[1000],top,n;

void add(int ct1,int ct2,int len,int cost)
{
    a[top].ct1=ct1;
    a[top].ct2=ct2;
    a[top].len=len;
    a[top].cost=cost;
    top++;
}

void Bellman(int s,int d)
{
    int i,j,check;
    memset(dis,inf,sizeof(dis));
    memset(dt,inf,sizeof(dt));
    dis[s]=0;
    dt[s]=0;
    for(i=1;i<n;i++)
    {
       check=0;
       for(j=0;j<top;j++)
       {
          if(dis[a[j].ct2] > dis[a[j].ct1]+a[j].len||(dis[a[j].ct2] == dis[a[j].ct1]+a[j].len &&dt[a[j].ct2] > dt[a[j].ct1]+a[j].cost))
          {
             dis[a[j].ct2] = dis[a[j].ct1]+a[j].len;
             dt[a[j].ct2] = dt[a[j].ct1]+a[j].cost;
             check=1;
          }
       }
       if(check==0)   break;
    }
    printf("%d %d\n",dis[d],dt[d]);
}
int main()
{
    int t,m,s,d,i,c1,c2,le,cos;
    scanf("%d",&t);
    while(t--)
    {
       top=0;
       scanf("%d%d%d%d",&n,&m,&s,&d);
       for(i=0;i<m;i++)
       {
          scanf("%d%d%d%d",&c1,&c2,&le,&cos);
          add(c1,c2,le,cos);
          add(c2,c1,le,cos);
       }
       Bellman(s,d);
    }
    return 0;
}

2.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define inf 0x3f3f3f3f
struct node
{
    int ct1,ct2,len,cost;
} a[1000];
struct note
{
    int minlen;
    int mincos;
} b[1000];
int top,n;

void add(int ct1,int ct2,int len,int cost)
{
    a[top].ct1=ct1;
    a[top].ct2=ct2;
    a[top].len=len;
    a[top].cost=cost;
    top++;
}

void Bellman(int s,int d)
{
    int i,j,check;
    memset(b,inf,sizeof(b));
    b[s].minlen=0;
    b[s].mincos=0;
    for(i=1; i<n; i++)
    {
        check=0;
        for(j=0; j<top; j++)
        {
            if(b[a[j].ct2].minlen > b[a[j].ct1].minlen+a[j].len||(b[a[j].ct2].minlen == b[a[j].ct1].minlen+a[j].len &&b[a[j].ct2].mincos > b[a[j].ct1].mincos+a[j].cost))
            {
                b[a[j].ct2].minlen = b[a[j].ct1].minlen+a[j].len;
                b[a[j].ct2].mincos = b[a[j].ct1].mincos+a[j].cost;
                check=1;
            }
        }
        if(check==0)   break;
    }
    printf("%d %d\n",b[d].minlen,b[d].mincos);
}
int main()
{
    int t,m,s,d,i,c1,c2,le,cos;
    scanf("%d",&t);
    while(t--)
    {
        top=0;
        scanf("%d%d%d%d",&n,&m,&s,&d);
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d%d",&c1,&c2,&le,&cos);
            add(c1,c2,le,cos);
            add(c2,c1,le,cos);
        }
        Bellman(s,d);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值