A Simple Problem with Integers(线段树区间修改和区间求和)

A Simple Problem with Integers

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.

题意:n个数进行Q次操作,对某一区间数据进行修改和查询某一区间的数据和,线段树模板题。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll a[100010];
struct z
{
    ll l,r,sum,lazy;
}tree[100010*4];
void pushdown(ll x)
{
    if(tree[x].lazy)
    {
        tree[2*x].lazy+=tree[x].lazy;
        tree[2*x+1].lazy+=tree[x].lazy;
        tree[x*2].sum+=tree[x].lazy*(tree[x*2].r-tree[x*2].l+1);
        tree[x*2+1].sum+=tree[x].lazy*(tree[x*2+1].r-tree[x*2+1].l+1);
        tree[x].lazy=0;
    }
}
void build(ll l,ll r,ll k)
{
    tree[k].l=l;
    tree[k].r=r;
    tree[k].lazy=0;
    if(l==r)
    {
        tree[k].sum=a[r];
        return;
    }
    ll mid=(l+r)/2;
    build(l,mid,k*2);
    build(mid+1,r,k*2+1);
    tree[k].sum=tree[k*2].sum+tree[k*2+1].sum;
}
void add(ll l,ll r,ll v,ll k)
{
    if(l<=tree[k].l&&r>=tree[k].r)
    {
        tree[k].sum+=v*(tree[k].r-tree[k].l+1);
        tree[k].lazy+=v;
        return;
    }
    pushdown(k);
    ll mid=(tree[k].l+tree[k].r)/2;
    if(l<=mid)
    add(l,r,v,k*2);
    if(r>mid)
    add(l,r,v,k*2+1);
    tree[k].sum=tree[k*2].sum+tree[k*2+1].sum;
}
ll query(ll l,ll r,ll k)
{
    if(l<=tree[k].l&&r>=tree[k].r)
    return tree[k].sum;
    pushdown(k);
    ll mid=(tree[k].l+tree[k].r)/2,ans=0;
    if(l<=mid)
    ans+=query(l,r,k*2);
    if(r>mid)
    ans+=query(l,r,k*2+1);
    return ans;
}
int main()
{
    ll n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        ll x,y,z,i,j;
        char r;
        for(i=1;i<=n;i++)
        scanf("%lld",&a[i]);
        build(1,n,1);
        while(m--)
        {
            getchar();
            scanf("%c",&r);
            if(r=='C')
            {
            	scanf("%lld%lld%lld",&x,&y,&z);
                add(x,y,z,1);   
            }
            else
            {
                scanf("%lld%lld",&x,&y);
                printf("%lld\n",query(x,y,1));
            }
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值