Cleaning Shifts(最小区间覆盖类问题)

Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2…N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1…7, cow #2 can work shifts 3…6, and cow #3 can work shifts 6…10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:打扫谷仓需要M天,现在有N头牛,每头牛只在一个时间间隔内工作,问怎样分配用到的牛最少。

题解:最小区间覆盖类的问题,先根据牛的工作时间做一个排序,然后每次找满足条件且覆盖范围最大的那个。

代码如下

#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct z{
    int left,right;
}a[100010];  //存入牛的工作范围 
bool cmp(z a,z b)  
{
    if(a.left==b.left)
    return a.right<b.right;  //排序 
    else
    return a.left<b.left;  
}  
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
    	int i,j,maxx=0,s=0,k=0,minn;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&a[i].left,&a[i].right);
            if(a[i].left>a[i].right)
            swap(a[i].left,a[i].right);
        }
        sort(a,a+n,cmp);
        while(maxx<m)
        {
            minn=maxx+1;   //将要覆盖的位置 
            for(i=k;i<n;i++)   
            {
            	if(a[i].left<=minn&&a[i].right>=minn)  //工作时间符合的牛 
            	{
            		if(maxx<a[i].right) //找到最划算的,即满足条件的情况下覆盖范围最大的 
            		maxx=a[i].right;     
				} 
                else if(a[i].left>minn)  //minn处无法被覆盖,结束循环 
                {
                    k=i;
                    break;
                }
			}
            if(minn>maxx)
            break;
            else
            s++;
        }
        if(maxx>=m)  //完全覆盖输出结果 
        printf("%d\n",s);
        else
        printf("-1\n");
    }
    return 0;
}
  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值