Cleaning Shifts(贪心 区间覆盖)

Cleaning Shifts
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output
  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input
    3 10
    1 7
    3 6
    6 10
    Sample Output
    2
    Hint
    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:第一行给出N和T,接着N行给出N个区间左右坐标,求出最少多少个区间可以完全覆盖1到T,如果无法完全覆盖输出-1;

思路:首先按照左坐标升序排列,如果左坐标相同,按右坐标升序排列。如果最左边的坐标不是1,那直接输出-1吧。接着看代码,太多细节了,这应该属于比较难的区间覆盖问题

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
//区间覆盖
const int maxn=25005;
const int INF=0x3f3f3f3f;
struct node
{
    int left;
    int right;
} point[maxn];
bool cmp(node x,node y)
{
    if(x.left==y.left)
        return x.right<y.right;
    return x.left<y.left;
}
int main()
{
    int N;//区间数量
    int T;//待覆盖区间
    while(~scanf("%d%d",&N,&T))
    {
        for(int i=0; i<N; i++)
            scanf("%d%d",&point[i].left,&point[i].right);
        sort(point,point+N,cmp);
        point[N].left=INF;
        int t=0;
        int temp=0;
        int result=0;
        bool flag=0;
        for(int i=0; i<N; i++)
        {
            if(point[i].left<=t+1)
            {
                if(temp<point[i].right)
                {
                    temp=point[i].right;
                    flag=1;
                }
                if(point[i+1].left>t+1&&flag)
                {
                    t=temp;
                    result++;
                    flag=0;
                }
            }
        }
        if(t>=T)
            printf("%d\n",result);
        else
            printf("-1\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值