UVa 10976----Fractions Again?!(枚举)

It is easy to see that for every fraction in the form  (k > 0), we can always find two positive integers x and y,x ≥ y, such that: 

.

Now our question is: can you write a program that counts how many such pairs of x and y there are for any givenk?

Input

Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000).

Output

For each k, output the number of corresponding (xy) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

Sample Input

2
12

Sample Output

2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24


结果输出是按y值的大小算的,求出y的取值范围是(k,2*k】.

求1/x,  1/x=1/k-1/y=(y-k)/k*y.但是这样会造成精度丢失,所以取倒数!!!


#include<bits/stdc++.h>
using namespace std;
int a[10010],b[10010];
int main()
{
	int k,count,i;
	while(~scanf("%d",&k))
	{
		count=0;
		for(i=k+1;i<=2*k;i++)
		{
			if(!(k*i%(i-k)))    //如判断条件为k*i/(i-k)则不对,因为x>y,所以y*k/x不一定是整数 
			{
				a[count]=k*i/(i-k);
				b[count]=i;
				count++;
			}	
		}
		
		printf("%d\n",count);   //当count=0时也输出 
		for(i=0;i<count;i++) printf("1/%d = 1/%d + 1/%d\n",k,a[i],b[i]);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值