Dice HDU - 5012(广搜)

There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)
在这里插入图片描述
Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A.

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
Sample Input
1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6
Sample Output
0
3
-1
两个筛子,如果可以通过绕着底部四条边使他们成为一样的,就输出最少的步数。如果不能的话就输出-1。
输出-1的情况就是相对的两个面不是一样的数字,其余的情况在六步内一定可以输出最少的步数。
读入的时候,依次是上下左右前后。
直接广搜给上就行。
代码如下:

#include<bits/stdc++.h>
using namespace std;
int vis1[10],vis2[10];
map<string,bool>mp;
int a[10],b[10];
struct node{
	int ans[10];
	int a;
};
bool check(node c)
{
	for(int i=1;i<=6;i++) if(c.ans[i]!=b[i]) return false;
	return true;
}
int bfs()
{
	mp.clear();
	queue<node> s;
	node x,z;
	string cnt="";
	for(int i=1;i<=6;i++) x.ans[i]=a[i],cnt+=a[i]+'0';
	x.a=0;
	mp[cnt]=1;
	s.push(x);
	while(s.size())
	{
		node y=s.front();
		s.pop();
		if(check(y)) return y.a;
		z.ans[1]=y.ans[6];z.ans[2]=y.ans[5];z.ans[3]=y.ans[3];z.ans[4]=y.ans[4];z.ans[5]=y.ans[1];z.ans[6]=y.ans[2];
		cnt="";for(int i=1;i<=6;i++) cnt+=z.ans[i]+'0';if(!mp[cnt]) z.a=y.a+1,mp[cnt]=1,s.push(z);
		z.ans[1]=y.ans[5];z.ans[2]=y.ans[6];z.ans[3]=y.ans[3];z.ans[4]=y.ans[4];z.ans[5]=y.ans[2];z.ans[6]=y.ans[1];
		cnt="";for(int i=1;i<=6;i++) cnt+=z.ans[i]+'0';if(!mp[cnt]) z.a=y.a+1,mp[cnt]=1,s.push(z);
		z.ans[1]=y.ans[4];z.ans[2]=y.ans[3];z.ans[3]=y.ans[1];z.ans[4]=y.ans[2];z.ans[5]=y.ans[5];z.ans[6]=y.ans[6];
		cnt="";for(int i=1;i<=6;i++) cnt+=z.ans[i]+'0';if(!mp[cnt]) z.a=y.a+1,mp[cnt]=1,s.push(z);
		z.ans[1]=y.ans[3];z.ans[2]=y.ans[4];z.ans[3]=y.ans[2];z.ans[4]=y.ans[1];z.ans[5]=y.ans[5];z.ans[6]=y.ans[6];
		cnt="";for(int i=1;i<=6;i++) cnt+=z.ans[i]+'0';if(!mp[cnt]) z.a=y.a+1,mp[cnt]=1,s.push(z);
	}
	return -1;
}
int main()
{
	while(scanf("%d",&a[1])!=EOF)
	{
		for(int i=2;i<=6;i++) scanf("%d",&a[i]);
		for(int i=1;i<=6;i++) scanf("%d",&b[i]);
		vis1[a[1]]=vis1[a[2]]=1;
		vis1[a[3]]=vis1[a[4]]=2;
		vis1[a[5]]=vis1[a[6]]=3;
		vis2[b[1]]=vis2[b[2]]=1;
		vis2[b[3]]=vis2[b[4]]=2;
		vis2[b[5]]=vis2[b[6]]=3;
		int flag=1;
		for(int i=1;i<=6;i+=2)
		{
			if(vis2[a[i]]!=vis2[a[i+1]])
			{
				flag=0;
				break;
			}
		}
		if(flag==0) printf("-1\n");
		else printf("%d\n",bfs());
	}
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值