Frogger POJ - 2253(spfa)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
思路:这个题目根最短路没啥关系其实,但是却体现了最短路的思想。
题目要求我们找到跳跃最大距离的最小值。第一想法是二分,但是二分的话,不是很好写,或者时间复杂度有点高。我们要找跳跃最大距离的最小值,就要遍历所有的路径,找到每一条路径的最大值,然后取最小的。这正是最短路的思想,因为最短路就是在所有的路径中找寻最小值。我们令dis数组代表着从1点到第i点的最大距离最小值,spfa求最短路的过程中不断的更新。(一定要选c++编译器,g++编译器一直wa)
代码如下:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=2e2+10;
struct node{
	int x,y;
}p[maxx];
double mp[maxx][maxx],dis[maxx];
int vis[maxx];
int n;

inline void spfa(int u)
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++) dis[i]=inf;//最好这样写,memset对浮点数好像不起作用
	dis[u]=0.0;
	vis[u]=1;
	queue<int> q;
	q.push(u);
	while(q.size())
	{
		int v=q.front();
		q.pop();
		vis[v]=0;
		for(int i=1;i<=n;i++)
		{
			if(dis[i]>max(dis[v],mp[v][i]))//!!!
			{
				dis[i]=max(dis[v],mp[v][i]);
				if(!vis[i])
				{
					vis[i]=1;
					q.push(i);
				}
			}
		}
	}
}
int main()
{
	int k=0;
	while(scanf("%d",&n),n)
	{
		for(int i=1;i<=n;i++) scanf("%d%d",&p[i].x,&p[i].y);
		memset(mp,0,sizeof(mp));
		for(int i=1;i<=n;i++)
		for(int j=i+1;j<=n;j++) mp[i][j]=mp[j][i]=sqrt((double)(p[i].x-p[j].x)*(p[i].x-p[j].x)+(double)(p[i].y-p[j].y)*(p[i].y-p[j].y));
		spfa(1);
		printf("Scenario #%d\n",++k);
		printf("Frog Distance = %.3lf\n",dis[2]);
		printf("\n");
	}
	return 0;
}

(ps poj真的lj)
努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值