Silver Cow Party POJ - 3268(正反建图+dijkstra)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
思路:思路很好想,就是正反建图,分别从x点跑最短路就可以,最后加起来求最大值。样例很坑,有重边。poj上,g++交的话,必须得用堆优化才可以过,否则超时(也有可能是我代码的问题,总之注意一下吧)。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=1e3+100;
int mp1[maxx][maxx],mp2[maxx][maxx];
struct node{
	int pos;
	int v;
	node(){}
	node(int a,int b){pos=a,v=b;}
	bool operator <(const node &a)const{
		return v>a.v;
	}
};
int dis1[maxx],dis2[maxx];
int vis[maxx];
int n,m,x,tot1,tot2;

inline void init()
{
	memset(dis1,inf,sizeof(dis1));
	memset(dis2,inf,sizeof(dis2));
	memset(mp1,inf,sizeof(mp1));
	memset(mp2,inf,sizeof(mp2));
	tot1=tot2=0;
}

inline void Dijkstra1(int u)
{
	memset(vis,0,sizeof(vis));
	priority_queue<node> p;
	p.push(node(u,0));
	dis1[u]=0;
	while(p.size())
	{
		node r=p.top();
		p.pop();
		int v=r.pos;
		if(vis[v]) continue;
		vis[v]=1;
		for(int i=1;i<=n;i++)
		{
			if(mp1[v][i]!=inf)
			{
				int to=i;
				int w=mp1[v][i];
				if(dis1[to]>dis1[v]+w) 
				{
					dis1[to]=dis1[v]+w;
					p.push(node(to,dis1[to]));
				}
			}
		}
	}
}
inline void Dijkstra2(int u)
{
	memset(vis,0,sizeof(vis));
	priority_queue<node> p;
	p.push(node(u,0));
	dis2[u]=0;
	while(p.size())
	{
		node r=p.top();
		p.pop();
		int v=r.pos;
		if(vis[v]) continue;
		vis[v]=1;
		for(int i=1;i<=n;i++)
		{
			if(mp2[v][i]!=inf)
			{
				int to=i;
				int w=mp2[v][i];
				if(dis2[to]>dis2[v]+w) 
				{
					dis2[to]=dis2[v]+w;
					p.push(node(to,dis2[to]));
				}
			}
		}
	}
}
int main()
{
	while(scanf("%d%d%d",&n,&m,&x)!=EOF)
	{
		init();
		int a,b,c;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			mp1[a][b]=mp2[b][a]=min(mp1[a][b],c);
		}
		for(int i=1;i<=n;i++) mp1[i][i]=mp2[i][i]=0;
		Dijkstra1(x);
		Dijkstra2(x);
		int _max=0;
		for(int i=1;i<=n;i++) _max=max(_max,dis1[i]+dis2[i]);
		printf("%d\n",_max);
	}
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值