The Moving Points HDU - 4717(三分)

There are N points in total. Every point moves in certain direction and certain speed. We want to know at what time that the largest distance between any two points would be minimum. And also, we require you to calculate that minimum distance. We guarantee that no two points will move in exactly same speed and direction.
Input
The rst line has a number T (T <= 10) , indicating the number of test cases.
For each test case, first line has a single number N (N <= 300), which is the number of points.
For next N lines, each come with four integers X i, Y i, VX i and VY i (-10 6 <= X i, Y i <= 10 6, -10 2 <= VX i , VY i <= 10 2), (X i, Y i) is the position of the i th point, and (VX i , VY i) is its speed with direction. That is to say, after 1 second, this point will move to (X i + VX i , Y i + VY i).
Output
For test case X, output "Case #X: " first, then output two numbers, rounded to 0.01, as the answer of time and distance.
Sample Input
2
2
0 0 1 0
2 0 -1 0
2
0 0 1 0
2 1 -1 0
Sample Output
Case #1: 1.00 0.00
Case #2: 1.00 1.00
思路:距离关于时间的函数,很明显是一个二次函数,先增后减。因此我们可以三分去做。对时间三分,但是要注意精度问题。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define esp 1e-10
using namespace std;

const int maxx=3e2+10;
struct node{
	double x;
	double y;
	double vx;
	double vy;
}p[maxx];
int n;

double check(double t)
{
	double maxn=0;
	for(int i=0;i<n;i++)
	{
		for(int j=i+1;j<n;j++)
		{
			double tx1=p[i].x+p[i].vx*t;
			double ty1=p[i].y+p[i].vy*t;
			double tx2=p[j].x+p[j].vx*t;
			double ty2=p[j].y+p[j].vy*t;
			maxn=max(maxn,sqrt((tx1-tx2)*(tx1-tx2)+(ty1-ty2)*(ty1-ty2)));
		}	
	}
	return maxn;
}

double cal()
{
	double l=0;
	double r=1e10;
	while(r-l>=esp)
	{
		double mid=(l+r)/2;
		double midd=(mid+r)/2;
		if(check(mid)>check(midd)) l=mid+esp;
		else r=midd-esp;
	}
	return l;
}

int main()
{
	int t;
	scanf("%d",&t);
	int k=0;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++) scanf("%lf%lf%lf%lf",&p[i].x,&p[i].y,&p[i].vx,&p[i].vy);
		double x=cal();
		printf("Case #%d: %.2lf %.2lf\n",++k,x,check(x));
	}
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值