Fliptile(状压+思维)

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
思路:不知道为啥这道题目会放在搜索专题上,可能搜索的方法也可以解决吧。
首先我们看数据量,最大是15.状压的一个很明显的特点就是数据量小。我们如果按照暴力的方法的话,数据量就特别大,肯定会超时。那么我们就将第一行是否翻转的情况枚举一下。
假如是m列的话,我们枚举0~(2^m-1)的数字,转换成二进制,就是01串。vis[i][j]=0就是不翻转,vis[i][j]=1代表翻转。
我们枚举了第一行的翻转情况,然后从第二行开始,如果该位置的上一个位置是黑色的话,这一个位置,是必须要翻转的。翻转完成之后,如果最后一行全是白色的话,就说明第一行的翻转是可行的,记录一下最小值。
题目要求字典序最小,我们枚举的顺序正好满足了字典序最小。
在这里插入图片描述
这是转换成二进制串的代码,结果如图所示:
在这里插入图片描述
代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=16;
int a[maxx][maxx];//原数组
int vis[maxx][maxx];//翻转数组
int ans[maxx][maxx];//答案数组
int d[][2]={{1,0},{0,1},{-1,0},{0,-1},{0,0}};//上下左右中
int n,m;

bool judge(int x,int y)//判断一个点的颜色,是这个点本身的颜色+翻转的次数;如果本身是白色的话,翻转奇数次是黑色;如果本身是黑色的话,翻转偶数次是黑色。这两种情况加起来都是奇数。
{
	int as=a[x][y];//本身的颜色
	for(int i=0;i<5;i++)
	{
		int tx=x+d[i][0];
		int ty=y+d[i][1];
		if(tx<0||tx>=n||ty<0||ty>=m) continue;
		as+=vis[tx][ty];//翻转的次数
	}
	return as&1;//判断是否为奇数
}
inline int solve()
{
	for(int i=1;i<n;i++)
	for(int j=0;j<m;j++) if(judge(i-1,j)) vis[i][j]=1;//判断上一个点是否为黑色,如果是黑色,这个点必须要翻转
	for(int i=0;i<m;i++) if(judge(n-1,i)) return -1;//最后一行如果有黑色的话,就说明这个情况不符合。
	int num=0;
	for(int i=0;i<n;i++) for(int j=0;j<m;j++) num+=vis[i][j];//记录一下翻转的次数
	return num;
}
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++) scanf("%d",&a[i][j]);
		}
		int flag=0,num;
		int Ans=inf;
		for(int i=0;i<(1<<m);i++)
		{
			memset(vis,0,sizeof(vis));
			for(int j=0;j<m;j++) vis[0][m-j-1]=(i>>j)&1;//转换成二进制串
			num=solve();
			if(num!=-1)
			{
				flag=1;
				if(num<Ans)
				{
					Ans=num;
					for(int o=0;o<n;o++) 
					{
						for(int p=0;p<m;p++) ans[o][p]=vis[o][p];
					}
				}
			}
		}
		if(!flag) cout<<"IMPOSSIBLE"<<endl;
		else 
		{
			for(int i=0;i<n;i++)
			{
				for(int j=0;j<m;j++) cout<<ans[i][j]<<" ";
				cout<<endl;
			}
		}
	}
	return 0;
}

努力加油a啊

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值