B - Prime Ring Problem HDU - 1016(深搜之素数环)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

学过深搜的人最熟悉的就是素数环吧。。深搜的入门题。
需要注意的是输出格式问题。如果因为格式错误wa了 的话,就太可惜了。hdu的简单题背后都有一个大坑,坑死你的哪种。
代码给上:

#include<iostream>
#include<cmath>
using namespace std;
int n,a[100],book[100];
int i_prime(int x)//判断是不是素数,最基本的素数筛法。如果是,就返回1,否则返回0。
{
	for(int i=2;i<=sqrt(x);i++)
	{
		if(x%i==0)
		return 0;
	}
	return 1;
}
void dfs(int step)
{
	if(step==n&&i_prime(book[0]+book[n-1]))//判断一下尾部和头部是不是素数。因为是一个环需要连起来。
	{
		for(int i=0;i<n;i++)
		{
			cout<<book[i];
			if(i<n-1) cout<<" ";//格式问题,唉
		}
		cout<<endl;
	}
	else for(int i=2;i<=n;i++)
	{
		if(!a[i]&&i_prime(book[step-1]+i))//这个数字没有用过并且和前面的加起来是个素数!!!。
		{
			book[step]=i;
			a[i]=1;//因为前面没有用过这里要用。就更新为1
			dfs(step+1);
			a[i]=0;//如果这种排列后面的不符合素数,就要返回来,还要更新为0。。
		}
	}
}
int main()
{
    int t=0;
	while(cin>>n)
	{
		
		book[0]=1;//都是从1开始
		cout<<"Case "<<++t<<":"<<endl;
		dfs(1);//从一开始搜
		cout<<endl;
	}
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值