Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
这个题目输出就是个坑,,除此之外,题目要求的是字符顺序最小,这就要求我们搜的时候的方向是确定得了。还要注意在存路径的时候要转换成大写字母。
代码如下:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int flag;
int a[101][101];//记录路径
int vis[101][101];//记录有没有走过,神奇的vis。
int d[][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//八个方向,这是确定的!!!
int p,q;//这是棋盘的大小,,
int dfs(int x,int y,int step)
{
a[step][0]=x;
a[step][1]=y;
if(step==q*p)//如果成立,就说明搜索完成,,
{
flag=1;
}
for(int i=0;i<8;i++)
{
int tx=x+d[i][0];
int ty=y+d[i][1];
if(tx<1||ty<1||tx>p||ty>q||vis[tx][ty]||flag) continue;//如果数组越界,这个点已经走过,或者已经完成搜索,就继续好了。
vis[tx][ty]=1;
dfs(tx,ty,step+1);
vis[tx][ty]=0;
}
return flag;
}
int main()
{
int n;
cin>>n;
int ans=0;
while(n--)
{
flag=0;
cin>>p>>q;
memset(vis,0,sizeof(vis));
vis[1][1]=1;//将第一个点更新为1。。
printf("Scenario #%d:\n",++ans);
if(dfs(1,1,1))
{
for(int i=1;i<=p*q;i++)
{
printf("%c%d",a[i][1]+'A'-1,a[i][0]);//注意格式问题
}
}
else printf("impossible");
printf("\n");
if(n!=0)
printf("\n");
}
return 0;
}
努力加油a啊,(o)/~