The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
这个题是求几个数的最小公倍数,但是本质上是求这几个数的最大公约数。因为最小公倍数就是两个数的乘积除以这两个数的最大公约数。记得用long long 类型,在这里wa了两次。
代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long
using namespace std;
const int maxx=1e6+10;
ll gcd(ll x,ll y)//欧几里得求最大公约数(辗转相除法)
{
if(y==0) return x;
else return gcd(y,x%y);
}
ll n;
ll a[maxx];
int main()
{
int t;
while(cin>>t)
{
while(t--)
{
cin>>n;
for(int i=0;i<n;i++)
{
cin>>a[i];
}
int ans=a[0];
for(int i=1;i<n;i++)
{
int cnt=gcd(ans,a[i]);
ans=ans*a[i]/cnt;
}
cout<<ans<<endl;
}
}
}
努力加油a啊,(o)/~