A - Anniversary party HDU - 1520(没有上司的舞会)

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output
Output should contain the maximal sum of guests’ ratings.
Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output
5

树形dp入门题目,上司和下属不能同时出现。。就要动态规划下去,看看怎样的布置才会使总价值最高。我觉得树形dp的题目还是需要用vector,虽然用数组啥的在poj上可以过去,但是在hdu上过不了。卡数据卡的太厉害了。
代码如下:

//正确代码:
#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
const int maxn=6005,inf=1<<30;
int dp[maxn][2];
int w[maxn],in[maxn];
int n,m;
vector<int>G[maxn];
void dfs(int u,int fa)
{
 
    dp[u][1]=w[u];
    dp[u][0]=0;
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if(v==fa) continue;
        dfs(v,u);
        dp[u][1]+=dp[v][0];
        dp[u][0]+=max(dp[v][1],dp[v][0]);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        int rt=1;
        for(int i=0;i<=n;i++) G[i].clear(),in[i]=0;
        for(int i=1;i<=n;i++) scanf("%d",&w[i]);
        int from,to;
        while(scanf("%d%d",&from,&to),from+to)
        {
            G[to].push_back(from);//建一条上司到下属的边
            in[from]++;
        }
        for(int i=1;i<=n;i++)
        if(in[i]==0) {rt=i;break;}
        dfs(rt,-1);
        int ans=max(dp[rt][0],dp[rt][1]);
        printf("%d\n",ans);
    }
    return 0;
}

但是我还是觉得把那个代码贴出来,毕竟在poj上可以过去哦
代码如下:
(错误代码)在hdu上过不去的,呜呜呜

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

const int maxx=6e3+10;
int dp[maxx][2];
int vis[maxx];
int ins[maxx];
int f[maxx];

void init()
{
	memset(dp,0,sizeof(dp));
	memset(vis,0,sizeof(vis));
	memset(ins,0,sizeof(ins));
	memset(f,0,sizeof(f));
}

int n,l,k,top;

void dfs(int top)
{
	vis[top]=1;
	for(int i=1;i<=n;i++)
	{
		if(vis[i]==0&&f[i]==top)
		{
			dfs(i);
			dp[top][1]+=dp[i][0];
			dp[top][0]+=max(dp[i][0],dp[i][1]);
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=1;i<=n;i++) cin>>dp[i][1];
		while(scanf("%d%d",&l,&k),l+k)
		{
			f[l]=k;
			ins[l]++;
		}
		for(int i=1;i<=n;i++)
		{
			if(ins[i]==0)
			{
				top=i;
				break;
			}
		}
		dfs(top);
		cout<<max(dp[top][1],dp[top][0])<<endl;
	}
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值