uva11538

11538 Chess Queen
You probably know how the game of chess is played and how chess queen operates. Two chess queens
are in attacking position when they are on same row, column or diagonal of a chess board. Suppose
two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be
in attacking positions in 12 ways, these are shown in the picture below:
Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways
Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking
position in that.
Input
Input file can contain up to 5000 lines of inputs. Each line contains two non-negative integers which
denote the value of M and N (0 < M, N ≤ 106
) respectively.
Input is terminated by a line containing two zeroes. These two zeroes need not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes in how
many ways two queens can be in attacking position in an (M × N) board, where the values of M and
N came from the input. All output values will fit in 64-bit signed integer.
Sample Input
2 2
100 223
2300 1000
0 0
Sample Output
12
10907100
11514134000

思路:
其实这道题含义是只要在同一行或同一列或同一对角线都可以攻击。行和列都很好想。每
1.行有m个,可以放m个,另外一个就只能放m-1个。一共n列就是mn(m-1)。
2.然后列的话也相同就是把行换成列mn(n-1)
3.下面是对角线形的,设m>n,看左下方向来说。设对角线长度为len。len就是1至m。对于每个len都有len*(len-1)的情况。然后有两次所以*2.下面考虑长度为m的有多少个。长度为m的主要又最长边决定,大家可以写写试试。然后就有(m-n+1)个,每个都有n个空,另外一个皇后就是n-1个空。然后因为还有右上所以乘二。就推出下面公式化简就行
在这里插入图片描述
在这里插入图片描述

#include <bits/stdc++.h>
using namespace std;
typedef long long int ll;
int main()
{
    ios::sync_with_stdio(false);
    ll a, b;
    while (cin >> a >> b && a&&b)
    {
        ll ans = 0;
        if (a > b) swap(a,b);
        cout << a * b*(a + b - 2) + 2 * a*(a - 1)*(3 * b - a - 1) / 3 << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值