3.魔咒词典

魔咒词典

题目

【问题描述】

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

输入形式

首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含非负整数N(0=<N<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出形式

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

样例输入

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

样例输出

light the wand
accio
what?
what?

解答

思路

  1. 结构体node包括魔咒words和功能fun
  2. 通过判断输入字符串首个字符是否为‘[’判断是魔咒还是功能;再依次检索输出对应魔咒和功能
  3. 用到的函数:
    字符数组是否相等
    函数名:int strcmp(*char1,*char2)
    头文件:
    当char1与char2相等时返回值为0;

代码

#include <iostream>
#include <cstring>
using namespace std;
struct node
{
    char words[20];
    char fun[80];
};
node spell[100000];
int main()
{
    int i = 0;
    for (i = 0; i < 100000; i++)
    {
        cin >> spell[i].words[0];
        int j = 1;
        while (1)
        {
            spell[i].words[j] = getchar();
            if (spell[i].words[j] == ']' || spell[i].words[j] == '@')
                break;
            j++;
        }
        if (strcmp(spell[i].words, "@END@") == 0)
            break;
        getchar();
        cin.getline(spell[i].fun, 80);
    }
    int n = 0;
    cin >> n;
    getchar();
    for (int j = 0; j < n; j++)
    {
        char a[80];
        cin.getline(a, 80);
        if (a[0] == '[')
        {
            for (int k = 0;; k++)
            {
                if (k == i)
                {
                    cout << "what?" << endl;
                    break;
                }
                if (strcmp(spell[k].words, a) == 0)
                {
                    cout << spell[k].fun << endl;
                    break;
                }
            }
        }
        else
        {
            for (int k = 0;; k++)
            {
                if (k == i)
                {
                    cout << "what?" << endl;
                    break;
                }
                if (strcmp(spell[k].fun, a) == 0)
                {
                    int len = strlen(spell[k].words);
                    for (int h = 1; h < len - 1; h++)
                        cout << spell[k].words[h];
                    cout << endl;
                    break;
                }
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小黄小黄不再偷懒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值