UVA10474 Where is the Marble?

UVA10474 Where is the Marble?

problem:
Raju and Meena love to play with Marbles. They have got a lot of
marbles with numbers written on them. At the beginning, Raju would
place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble
with a certain number. She would count 1…2…3. Raju gets one point
for correct answer, and Meena gets the point if Raju fails. After some
fixed number of trials the game ends and the player with maximum
points wins. Today it’s your chance to play as Raju. Being the smart
kid, you’d be taking the favor of a computer. But don’t underestimate
Meena, she had written a program to keep track how much time you’re
taking to give all the answers. So now you have to write a program,
which will help you in your role as Raju.

Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins
with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next
N lines would contain the numbers written on the N marbles. These marble numbers will not come
in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers
are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.

Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether
or not the query number is written upon any of the marbles. The two different formats are described
below:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered
1, 2, . . . , N.
• ‘x not found’, if the marble with number x is not present.
Look at the output for sample input for details.

Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

最近在跟着刘汝佳的书学习STL,这道题算是比较简单的入门,但我刚开始有一点问题是关于lower_bound的使用。写一点东西方便自己学习。

1.lower_bound:返回数组中第一个大于等于该元素的下标,upper_bound:返回数组中第一个大于该元素的下标(注意两个都是返回的下标迭代器,不是下标数字)

2.函数原型:
//在 [first, last) 区域内查找不小于 val 的元素
ForwardIterator lower_bound (ForwardIterator first, ForwardIterator last,const T& val);
//在 [first, last) 区域内查找第一个不符合 comp 规则的元素
ForwardIterator lower_bound (ForwardIterator first, ForwardIterator last,const T& val, Compare comp);

3.pos是lower_bound的返回值,pos不是一定就指到我们要找的这个值的,这个值可能不存在这个容器里面,它会指向第一个大于等于这个值的位置,所以返回的这个pos指向的值是不是我们要的值,如果不是,说明容器里面没有这个值。(而且还有可能整个容器里的值都小于我们要找的值,那这样,pos指向的是vector.end())

代码如下:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main(void){
	int n,q,cnt = 0;
	cin >> n >> q;
	while(n!=0 && q!=0){
		int i;
		vector<int> marbles;
		vector<int>::iterator iter;
		marbles.clear();
		cnt ++;
		for(i=0; i<n; i++){
			int num;
			cin >> num;
			marbles.push_back(num);
		}
		sort(marbles.begin(),marbles.end());
		cout << "CASE# " << cnt << ":\n"; 
		for(i=0; i<q; i++){
			int findn,result = 1;
			vector<int>::iterator pos;
			cin >> findn;
			pos = lower_bound(marbles.begin(),marbles.end(),findn);
			for(iter = marbles.begin(); iter < marbles.end(); iter++){
				if(iter == pos) break;
				else{
					result++;
				}
			}
			if(iter == marbles.end() || *iter != findn){
				cout << findn << " not found\n";
			}
			else{
				cout << findn << " found at " << result << endl;
			}
		}
		cin >> n >> q;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值