couple

Description N couples are standing in a circle, numbered consecutively
clockwise from 1 to 2N. Husband and wife do not always stand together.
We remove the couples who stand together until the circle is empty or
we can’t remove a couple any more.

Can we remove all the couples out of the circle?

Input There may be several test cases in the input file. In each case,
the first line is an integer N(1 <= N <= 100)—-the number of
couples. In the following N lines, each line contains two integers
—- the numbers of each couple. N = 0 indicates the end of the input.

Output Output “Yes” if we can remove all the couples out of the
circle. Otherwise, output “No”.

Sample Input 4 1 4 2 3 5 6 7 8

2 1 3 2 4

6 1 12 2 11 3 10 4 9 5 6 7 8

7 1 14 4 13 2 3 5 10 12 11 6 9 7 8

0 Sample Output Yes No Yes Yes

#include <stdio.h>

#define MAXn (1000*2)

int s[MAXn], q[MAXn];

int main() {
    int a, b, n, p, i;
    for (scanf("%d", &n); n > 0; scanf("%d", &n)) {
        for (i = 0; i < n; ++i) {
            scanf("%d%d", &a, &b);
            q[a-1] = q[b-1] = i;
        }
        p = 0;
        n *= 2;
        for (i = 0; i < n; ++i)
            if (p > 0 && s[p-1] == q[i])//借用一个s数组来判断是否相邻的数字相同。
                --p;
            else
                s[p++] = q[i];
        if (p > 0)//只有p小于0时,才能yes
            printf("No\n");
        else
            printf("Yes\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值