1010. Zipper

Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. For example, consider forming “tcraete” from “cat” and “tree”: String A: cat String B: tree String C: tcraete As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”: String A: cat String B: tree String C: catrtee Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.
Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
Output
For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
Sample Input
Copy sample input to clipboard
3
cat tree tcraete
cat tree catrtee
cat tree cttaree
Sample Output
Data set 1: yes
Data set 2: yes
Data set 3: no

CPP

#include <iostream>
#include <string>
#include <cstring>
using namespace std;

const int N = 205;

string a, b, c;
bool dp[N][N];

int main()
{
    int cases;
    int num = 0;

    cin >> cases;

    while (cases--)
    {
        num++;
        cin >> a >> b >> c;

        memset(dp, false, sizeof(dp));

        dp[0][0] = true;

        for (int i = 0; i < b.size(); i++)
            if (b[i] == c[i])
                dp[0][i+1] = true;//
            else
                break;

        for (int i = 0; i < a.size(); i++)
            if (a[i] == c[i])
                dp[i+1][0] = true;
            else
                break;
        //确定c最初几个字母的归属
        for (int i = 1; i <= a.size(); i++)
            for (int j = 1; j <= b.size(); j++)
                dp[i][j] = (dp[i-1][j] && c[i+j-1] == a[i-1]) || (dp[i][j-1] && c[i+j-1] == b[j-1]);
        //通过二维数组来确定
        //判断条件需学会!
        if (dp[a.size()][b.size()])
            cout << "Data set "<< num << ": yes" << endl;
        else
            cout << "Data set "<< num << ": no" << endl;
    }
    return 0;
}

C (有未知bug!)

#include <stdio.h>
#include <string.h>
int main() {
    int n;
    scanf("%d", &n);
    int k;
    for (k = 1; k <= n; k++) {
        char a[200], b[200], c[200];
        scanf("%s%s%s", a, b, c);
        int dp[200][200];
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        for (int i = 0; i < strlen(b); i++) {
            if (b[i] == c[i]) {
                dp[0][i + 1] = 1;
            } else {
                break;
            }
        }
        for (int i = 0; i < strlen(a); i++) {
            if (a[i] == c[i]) {
                dp[i + 1][0] = 1;
            } else {
                break;
            }
        }
        for (int i = 1;i <= strlen(a); i++) {
            for (int j = 1; j <= strlen(b); j++) {
                dp[i][j] = (dp[i - 1][j] && c[i + j - 1] == a[i - 1]) || (dp[i][j - 1] && c[i + j - 1] == b[j - 1]);
            }
        }
        if (dp[strlen(a)][strlen(b)]) {
            printf("Data set %d: yes\n", k);
        } else {
            printf("Data set %d: no\n", k);
        }
    }
    return 0;
}

此题是通过定义一个二维数组,前一个变量确定a后一个变量确定b
判断条件尤其重要!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值