hdu1198 Farm Irrigation 并查集或者dfs

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.


Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like


 

Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

 


Input
There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.
 


Output
For each test case, output in one line the least number of wellsprings needed.
 


Sample Input
2 2 DK HF 3 3 ADC FJK IHE -1 -1
 


Sample Output
2 3
 
题目很好理解,也容易想出思路,只是这里需要进行一个模型的转换,可用并查集算或者是DFS。
先上个代码
#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>

#define TOP 0
#define RIGHT 1
#define BOTTOM 2
#define LEFT 3

using namespace std;
const int N = 55;
int f[2550];
char mp[N][N];
map<int, int> mpx;
bool mode[11][4] = {
	{1, 0, 0, 1},
	{1, 1, 0, 0},
	{0, 0, 1, 1},
	{0, 1, 1, 0},
	{1, 0, 1, 0},
	{0, 1, 0, 1},
	{1, 1, 0, 1},
	{1, 0, 1, 1},
	{0, 1, 1, 1},
	{1, 1, 1, 0},
	{1, 1, 1, 1}
};
int fin(int t)
{
	if(f[t] == -1) return t;
	return f[t] = fin(f[t]);
}
void bing(int a, int b)
{
	int t1 = fin(a);
	int t2 = fin(b);
	if(t1 != t2)
		f[t1] = t2;
}
int main()
{
	char buf[N];
	int ans, m, n;
	// freopen("tmp.in", "r", stdin);
	while(~scanf("%d%d", &m, &n))
	{
		memset(f, 0xff, sizeof(f));
		mpx.clear();
		ans = 0;
		if(m <= 0 || n <= 0) break;
		for(int i = 1; i <= m; i++)
		{
			scanf("%s", buf);
			for(int j = 1; j <= n; j++)
				mp[i][j] = buf[j - 1] - 'A';
		}
		for(int i = 1; i <= m; i++)
			for(int j = 1; j <= n; j++)
			{
				if(j != n && mode[mp[i][j]][RIGHT] && mode[mp[i][j + 1]][LEFT])
					bing(j + (i - 1) * n, j + 1 + (i - 1) * n);
				if(i != m && mode[mp[i][j]][BOTTOM] && mode[mp[i + 1][j]][TOP])
					bing(j + (i - 1) * n, j + i * n);
			}
		int x = m * n;
		for(int i = 1; i <= x; i++)
		{
			int tmp = fin(i);
			if(mpx.find(tmp) == mpx.end())
			{
				ans++;
				mpx[tmp] = 1;
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}
我这里用了一个mode来保存所有的土地的形状。
顺序是上右下左,和css一致。 如果mode[x][y]为1的话, 说明x这块土地的y方向是有沟的(必火)
所以就是先把整个土地读进来,然后一块一块判断每个土地和右边,和下边的连通情况。然后如果连通,就用并查集连起来。这里把所有土地做了个编号。
类似这样。
1 2 3 4
5 6 7 8
9 10 11 12
然后查询有几个集合就行了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值