The Unique MST POJ1679

题目:

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意:

判断最小生成树是否唯一,如果唯一啧输出长度,否则输出“Not Unique!”;

先进行一次Kruskal,保存下来每一条边,之后再依次将每一条边都删除进行Kruskal,如果有结果与第一次相同则直接输出

Not Unique!;

注意:

进行完kruskal后一定要判断是否依然连通,如果不连通一定要返回小于0的数(因为返回0wa了好多次)

同时在kruskal中记得初始化;

代码:

#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<string.h>
using namespace std;
struct edge
{
    int u,v,w;
}e[10005];
int n,m,t;
int f[105];
int num[10005];
bool book[10005];
void intt()
{
    for(int i=0;i<=n;i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return  f[v];
    }
}
bool mergee(int v,int u)
{
    int t1,t2;
    t1=getf(v);
    t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
bool cmp(const edge &a,const edge &b)
{
    return a.w<b.w;
}
int Kruskal(int a)//消失哪一条边
{
    int sum=0;
    int countt=0;
    intt();
    for(int i=1;i<=m;i++)
    {
        if(i==a)//跳过需要消失的那条边
            continue;
        if(mergee(e[i].u,e[i].v))
        {
            countt++;
            sum+=e[i].w;
            //printf("%d\n",sum);
            if(a==0)//记录最小生成树的边
                book[i]=1;
        }
        if(countt==n-1)
            break;
    }
    for(int i=1;i<n;i++)//已经无法连通
    {
        if(getf(i)!=getf(i+1))
        {
            return -1;
        }
    }
    return sum;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        for(int i=1;i<=m;i++)
        {
           scanf("%d %d %d",&e[i].u,&e[i].v,&e[i].w);
        }
        intt();
        memset(book,0,sizeof(book));
        bool flag=0;
        sort(e+1,e+m+1,cmp);
        int ans=Kruskal(0);//第一次哪一条边也不消失
        //printf("%d\n",ans);
        for(int i=1;i<=m;i++)
        {

            if(book[i])
            {
                int cnt=Kruskal(i);
                if(cnt==ans)
                {
                    flag=1;
                    break;
                }
            }
        }
        if(flag)
            printf("Not Unique!\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}
 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值