ACM DP Tickets

9 篇文章 0 订阅

题目:

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am


题意:

给出为每个人买票的时间,以及相邻两个人买票的所花的时间;

分析:

应该是DP刚开始学吧,其实是很简单的一个问题,我的做法是,立足当前的点n,分类第n-1 和n-2是否联合,以及该点是否和上一个点联合;其实最开始我是还想着n与后面的点的关系,其实前面的分析,已经不用考虑后面的了,这样一来就是重复考录计算;

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[2222];
int a[2222],b[2222];
int main()
{
    int n,k,t,h,s,m;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
            scanf("%d",&a[i]);
        for(int j=2;j<=k;j++)
            scanf("%d",&b[j]);
        dp[0]=0;//初始化
        dp[1]=a[1];
        for(int i=2;i<=k;i++)
        {
            dp[i]=min((dp[i-1]+a[i]),(dp[i-2]+b[i]));
        }
        t=dp[k];
        h=t/3600+8;
        s=t/60%60;
        m=t%60;
        if(h<12)
        printf("%02d:%02d:%02d am\n",h,s,m);
        else
            printf("%02d:%02d:%02d pm\n",h-12,s,m);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值