Frogger

题目:

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


题意:

给出两个青蛙所在石头的坐标,以及其他n-2个石头,问一号青蛙找二号青蛙的最小跳跃范围是多少

分析:

所谓的最小跳跃范围,你可以认为是该青蛙至少拥有多少跳跃能力才可以找到二号青蛙,也就是说假设有m条路径,求出这些路径中最大值最小的那一条,并将这个最大值输出,那么怎么和最短路径联系起来呢,我们首先要明白最短路径的原理,每次尝试看有没有新的点加入使得之前的两个点的距离变得更小(将x条边变成x+1条),或者说由一条边变成两条边,既然两条边的和比之前的一条小,自然的分开的这两条肯定更小,我们用dis[i]装1到i石头的最小跳跃范围,他所在的也就是对应的最短路径了,我们每次求出离1石头跳跃范围最小的石头,然后用这个石头不断更新其他的石头的跳跃范围

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#define inf 9999999
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
using namespace std;
double edge[209][209],dis[209];
int xx[209],yy[209];
double dist(int a,int b)
{
    return  sqrt((double)(xx[a]-xx[b])*(xx[a]-xx[b])+(yy[a]-yy[b])*(yy[a]-yy[b]));
}
bool used[209];
int main()
{
    int n,t=0;
    while(scanf("%d",&n)!=EOF)
        {
        if(n==0)    break;
        t++;
        memset(xx,0,sizeof(xx));
        memset(yy,0,sizeof(yy));
        memset(edge,0,sizeof(edge));
        for(int i=1;i<=n;i++)
            scanf("%d%d",&xx[i],&yy[i]);
        for(int i=1;i<n;i++)
            for(int j=i+1;j<=n;j++)
                edge[j][i]=edge[i][j]=dist(i,j);
        for(int i=1;i<=n;i++)
            {
            used[i]=0;
            dis[i]=inf;
            }
        dis[1]=0;
        used[0]=1;
        for(int i=1;i<=n-1;i++)
        {
            int p,minn=inf;
            for(int j=1;j<=n;j++)
                if(used[j]==0&&minn>dis[j])
                {
                    minn=dis[j];
                    p=j;
                }
            used[p]=1;
            for(int j=1;j<=n;j++)
                dis[j]=min(dis[j],max(dis[p],edge[j][p]));
        }
        printf("Scenario #%d\n",t);
        printf("Frog Distance = %.3f\n",dis[2]);
        printf("\n");


    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值