Frogger(POJ-2253)

POJ - 2253 传送门

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4
3
17 4
19 4
18 5
0

Sample Output

Scenario #1
Frog Distance = 5.000
Scenario #2
Frog Distance = 1.414


题目大意

1号石头是青蛙A的
2号石头是青蛙B的
其他石头是不属于任何人的石头(青蛙A可以借助这些石头跳到青蛙B的石头上)
Unfortunately Fiona’s stone is out of his jump range(不幸的是青蛙B的位置超过了青蛙A的一次弹跳范围)

理解要我们求的是什么:

(搞了好久才搞明白是求这个)
假设青蛙A跳到青蛙B有多条不同的路径,每一条路径都有单次跳跃的最大距离,我们要求的就是多条路径中单次跳跃的最大距离中的最短距离

解题思路

第一次是用 Dijkstra 写的,修改一下 Dijkstra 松弛操作即可
后面在复习 Floyd 的时候补了一个 Floyd 的写法,加深印象


Dijkstra - AC代码
#include<iostream>
#include<algorithm>
#include<string.h>
#include<cmath>
using namespace std;
const int maxn = 1e4;
const double inf  = 0x3f3f3f;
double map[maxn][maxn];
int n;
double dis[maxn];
int vis[maxn];
//int sum = 0;
struct Point
{
	double x;
	double y;
}p[maxn];
double distance(int a , int b)
{
	return sqrt((p[a].x - p[b].x)*(p[a].x - p[b].x) + (p[a].y - p[b].y)*(p[a].y - p[b].y));
}
void Dijkstra()
{
	for(int i = 1 ; i <= n ; i++)
	{
		dis[i] = map[1][i];
	}

	vis[1] = 1;
	dis[1] = 0;

	for(int i = 2 ; i <= n ; i++)
	{
		double min = inf;
		int pos = 0;
		for(int j = 1 ; j <= n ; j++)
		{
			if(vis[j] == -1 && dis[j] < min)
			{
				min = dis[j];
				pos = j;
			}
		}

		vis[pos] = 1;
		//sum += min;

		//for(int k = 1 ; k <= n ; k++)//原 Dijkstra 松弛操作
		//{
		//	if(vis[k] == -1 && dis[k] > min + map[pos][k])
		//	{
		//		dis[k] = min + map[pos][k];
		//	}
		//}

		for(int k = 1 ; k <= n ; k++)//Dijkstra 松弛操作变形
		{
			if(vis[k] == -1 && dis[k] > max(min,map[pos][k]))
			{
				dis[k] = max(min,map[pos][k]);
			}
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		if( n == 0 )
		{
			break;
		}
		static int count = 1;
		memset(vis,-1,sizeof(vis));
		for(int i = 1 ; i <= n ; i++)
		{
			scanf("%lf %lf",&p[i].x,&p[i].y);
		}
		for(int i = 1 ; i < n ; i++)
		{
			for(int j = i+1 ; j <= n ; j++)
			{	
				double d = distance(i,j);
				map[i][j] = map[j][i] = d;
			}
		}
		Dijkstra();
		printf("Scenario #%d\n",count);
		printf("Frog Distance = %.3f\n",dis[2]);
		printf("\n");
		count++;
	}
	return 0;
}

Floyd介绍

Floyd:(适用多源点最短路)

  • 时间复杂度:O(n3
  • 空间复杂度:O(n2
  • 动态规划思想
  • f[i][j]表示 i 到 j 经过小于 k 的点所能得到的临时最短路径
  • 枚举中转点 k
  • if( f[i][k] + f[k][j] <= f[i][j] )更新i 到 j 的最短距离 f[i][j] = f[i][k] + f[k][j]

Floyd - AC代码
#include<iostream>
#include<algorithm>
#include<string.h>
#include<cmath>
using namespace std;
const int maxn = 1e4;
//const double inf  = 0x3f3f3f;
double map[maxn][maxn];
int n;
//double dis[maxn];
//int vis[maxn];
//int sum = 0;
struct Point
{
	double x;
	double y;
}p[maxn];
double distance(int a , int b)
{
	return sqrt((p[a].x - p[b].x)*(p[a].x - p[b].x) + (p[a].y - p[b].y)*(p[a].y - p[b].y));
}
void Floyd()
{
	for(int k = 1 ; k <= n ; k++)
	{
		for(int i = 1 ; i <= n ; i++)
		{
			for(int j = 1 ; j <= n ; j++)
			{
				if(i != j && j != k && k != i)
				{
					//if(map[i][k] + map[k][j] <= map[i][j])
					//{
					//	map[i][j] = map[i][k] + map[k][j];
					//}
					if(max(map[i][k] , map[k][j]) <= map[i][j])
					{
						map[i][j] = max(map[i][k] , map[k][j]);
					}
					//多条路径中单次跳跃的最大距离中的最短距离
				}
			}
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		if( n == 0 )
		{
			break;
		}
		static int count = 1;
		//memset(vis,-1,sizeof(vis));
		for(int i = 1 ; i <= n ; i++)
		{
			scanf("%lf %lf",&p[i].x,&p[i].y);
		}
		for(int i = 1 ; i < n ; i++)
		{
			for(int j = i+1 ; j <= n ; j++)
			{
				double d = distance(i,j);
				map[i][j] = map[j][i] = d;
			}
		}
		Floyd();
		printf("Scenario #%d\n",count);
		printf("Frog Distance = %.3f\n",map[1][2]);
		printf("\n");
		count++;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值