poj1019


Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34343 Accepted: 9860

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
源代码
#include <iostream>
#include <cmath>
using namespace std;
unsigned int a[31270],b[31270];
void reset()
{
    a[1]=1;b[1]=1;
    for(int i=2;i<31270;i++){
        a[i]=a[i-1]+(int)log10((double)i) + 1;
        b[i]=b[i-1]+b[i];
    }
}
int data(int n)
{
    int i=1,length=0,k;
    while(b[i]<n) i++;
    int l=n-b[i-1];
    for (i=1;length<l;i++){
        length+=(int)log10((double)i)+1;
    }
 k=((i-1)/(int)pow((double)10,length-l))% 10;
    return k;
}
 
int main()
{
    int m,n;
    reset();
    cin>>m;
    while(m--){
        cin>>n;
        cout<<data(n)<< endl;
    }
    return 0;
}
很水的一道题,主要就是把题目读懂,还有就是数据类型转换。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值