POJ 3468 A Simple Problem with Integers (线段树,区间更新)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 61346 Accepted: 18734
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


<pre name="code" class="cpp">#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <sstream>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <stack>
#include <ctime>
#include <fstream>

#define L(x) x<<1
#define R(x) (x<<1)+1

using namespace std;
typedef long long LL;
struct node{
	int l,r;
	LL add,sum;
}t[100001*4];

LL num[100001];

void build(int l,int r,int x){
	t[x].l = l;
	t[x].r = r;
	t[x].add = 0;
	if(l == r){
		t[x].sum = num[l];		
		return ;
	}
	
	int mid = (t[x].l+t[x].r)>>1;
	build(l,mid,L(x));
	build(mid+1,r,R(x));	
	t[x].sum = t[L(x)].sum+t[R(x)].sum;
}

void update(int l,int r,int x,int c){
	if(l<=t[x].l && r>=t[x].r){
		t[x].add = t[x].add + c;
		t[x].sum += c*(t[x].r-t[x].l+1);
		return;
	}
	
	if(t[x].add){
		t[L(x)].add += t[x].add;
		t[L(x)].sum += t[x].add*(t[L(x)].r-t[L(x)].l+1);
		t[R(x)].add += t[x].add;
		t[R(x)].sum += t[x].add*(t[R(x)].r-t[R(x)].l+1);
		t[x].add = 0;
	}
	
	int mid = (t[x].l+t[x].r)>>1;
	if(l<=mid){
		update(l,r,L(x),c);
	}
	if(r>mid){
		update(l,r,R(x),c);
	}
	
	t[x].sum = t[L(x)].sum + t[R(x)].sum;
	
}

LL query(int l, int r,int x){
	if(l<=t[x].l && r>=t[x].r){
		return t[x].sum;
	}
	
		if(t[x].add){
		t[L(x)].add += t[x].add;
		t[L(x)].sum += t[x].add*(t[L(x)].r-t[L(x)].l+1);
		t[R(x)].add += t[x].add;
		t[R(x)].sum += t[x].add*(t[R(x)].r-t[R(x)].l+1);
		t[x].add = 0;
	}		

	int mid = (t[x].l+t[x].r)>>1;
	if(r<=mid){
	return query(l,r,L(x));
	}else if(l>mid){
	return query(l,r,R(x));
	}else{
		return query(l,mid,L(x))+query(mid+1,r,R(x));
	}
	
}
int main() {
	int n,q;
	
	while(scanf("%d%d",&n,&q)!=EOF){
		memset(num,0,sizeof(num));
		int i = 0;
		for(i = 1;i<=n;i++){
			scanf("%I64d",&num[i]);
		}
		build(1,n,1);
		while(q--){
			char s[10];
			scanf("%s",s);
			if(s[0] == 'Q'){
				int a,b,c;
				scanf("%d%d",&a,&b);
                printf("%I64d\n",query(a,b,1));
			}else if(s[0] == 'C'){
				int a,b,c;
				scanf("%d%d%d",&a,&b,&c);
            	update(a,b,1,c);
			}
		}
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值