POJ 2243 Knight Moves (bfs)

Knight Moves
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13925 Accepted: 7766

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


搜索中基础的题目。用bfs和dfs都可行,这里使用的是bfs。

(实在想吐槽vs的scanf_s,字符输入怎么都报错)



#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
#include <algorithm>

using namespace std;

bool visit[9][9];
int dir[8][2] = { -1, -2, -2, -1, 1, -2, 2, -1, 1, 2, 2, 1, -1, 2, -2, 1 };


struct State
{
	int x, y;
	int stepCnt;
};


bool CheckState(State s)
{
	if (!visit[s.x][s.y] && s.x >= 1 && s.x <= 8 && s.y >= 1 && s.y <= 8)
		return true;
	else
		return false;
}

State bfs(State st, State ed)
{
	queue<State> q;
	State now, next;
	st.stepCnt = 0;
	q.push(st);
	visit[st.x][st.y] = true;
	while (!q.empty())
	{
		now = q.front();
		if (now.x == ed.x && now.y == ed.y)
		{
            return now;
		}

		for (int i = 0; i < 8; i++)
		{
			next.x = now.x + dir[i][0];
			next.y = now.y + dir[i][1];
			next.stepCnt = now.stepCnt + 1;
			if (CheckState(next))
			{
				q.push(next);
				visit[next.x][next.y] = true;
			}
		}
		q.pop();
	}
}


int main()
{
    State re, st, ed;
    char csx, csy, cdx, cdy;
    while(scanf("%c%c %c%c%*c", &csx, &csy, &cdx, &cdy) != EOF)
	{
		st.x = csx - 'a' + 1;
		st.y = csy - '0';
		ed.x = cdx - 'a' + 1;
		ed.y = cdy - '0';
		st.stepCnt = ed.stepCnt = 0;
		memset(visit, false, 81);
		re = bfs(st, ed);
		cout << "To get from " << csx << csy << " to " << cdx << cdy
				<< " takes " << re.stepCnt << " knight moves." << endl;
	}

	return 0;
}






“Let the Sun Shine upon this Lord of Cinder!”

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值