HDU 5532 2015ACM-ICPC长春赛区现场赛F题

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3582 Accepted Submission(s): 908

Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a_1, a_2, \ldots, a_n, is it almost sorted?

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a_1, a_2, \ldots, a_n.

1 \le T \le 2000
2 \le n \le 10^5
1 \le a_i \le 10^5
There are at most 20 test cases with n > 1000.

Output
For each test case, please output “YES” if it is almost sorted. Otherwise, output “NO” (both without quotes).

Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5

Sample Output
YES
YES
NO

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题意:去掉一个数,问是否能使序列变成单调的

思路:之前一直是用模拟做的,其实可以直接算一下LIS,正着反着都算一遍,O(ologn)

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main() {
    int T, n, i, j, k, a[100005], k1, k2, ans[100005], len, b[100005], flag;
    scanf("%d", &T);
    while (T--) {
        flag = 0;
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(ans, 0, sizeof(ans));
        k1 = k2 = 0;
        scanf("%d", &n);
        for (i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        ans[1] = a[1];
        len = 1;
        for (i = 2; i <= n; i++) {
            if (a[i] >= ans[len]) {
                ans[++len] = a[i];
            } else {
                int pos = upper_bound(ans + 1, ans + len + 1, a[i]) - ans;
                ans[pos] = a[i];
            }
        }
        if (len == n - 1 || len == n) {
            printf("YES\n");
            continue;
        }
        for (i = 1; i <= n; i++) {
            b[i] = a[n - i + 1];
        }
        ans[1] = b[1];
        len = 1;
        for (i = 2; i <= n; i++) {
            if (b[i] >= ans[len]) {
                ans[++len] = b[i];
            } else {
                int pos = upper_bound(ans + 1, ans + len + 1, b[i]) - ans;
                ans[pos] = b[i];
            }
        }
        if (len == n - 1 || len == n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值