HDU 5533 2015ACM-ICPC长春赛区现场赛G题

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1410 Accepted Submission(s): 787

Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.

Output
For each test case, please output “YES” if the stars can form a regular polygon. Otherwise, output “NO” (both without quotes).

Sample Input
3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

Sample Output
NO
YES
NO

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题意
输入数字n,和n个点的坐标,判断是否是正n变形

思路
因为所有坐标都是整数,可以推断出一个结论,必须是正四边形时才有可能成立,所以只要判断是不是矩形即可

可是,没想到这个结论该怎么办?
其实因为n<=100,所以可以把每两个坐标连条边排序,最小的n条边相等那么就是正n边形

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
double x, y, a[110], b[110];
double f(double q, double w) {
    return sqrt((q - x) * (q - x) + (w - y) * (w - y));
}
int main() {
    int T, n;
    scanf("%d", &T);
    while (T--) {
        scanf("%d", &n);
        x = y = 0;
        for (int i = 0; i < n; i++) {
            scanf("%lf%lf", &a[i], &b[i]);
            x += a[i] / n;
            y += b[i] / n;
        }
        double tmp = f(a[0], b[0]);
        int pos = 1;
        for (int i = 1; i < n; i++) {
            if (f(a[i], b[i]) != tmp) {
                pos = 0;
                break;
            }
        }
        if (pos)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值