hdu 5437 Alisha’s Party 优先队列

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3347 Accepted Submission(s): 869

Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

Input
The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,…,nq separated by a space, which means Alisha wants to know who are the n1−th,…,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input
1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3

Sample Output
Sorey Lailah Rose

Source
2015 ACM/ICPC Asia Regional Changchun Online

优先队列
注意细节,考虑周全

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>

using namespace std;
const int N=15e4+10;

struct people
{
    char name[210];
    long long v;
    int come;    //来的顺序
}a[N];

struct opendoor
{
    int rk;   //第几个到
    int ac;   //让几个进
    opendoor()
    {
        rk=0;
        ac=0;
    }
}d[N];

struct cmp                            ///优先队列,重载排序
{
    bool operator () (const people &a,const people &b)
    {
        if(a.v==b.v)
            return a.come>b.come;
        return a.v<b.v;
    }
};

int cmp1(const opendoor &a,const opendoor &b)
{
    return a.rk<b.rk;
}

void init(int k)
{
    for(int i=1;i<=k;i++)
        a[i].come=i;
}

int main()
{
    int t,k,m,q;
    scanf("%d",&t);
    while(t--)
    {
        priority_queue<people,vector<people>,cmp> que;
        scanf("%d%d%d",&k,&m,&q);
        init(k);
        for(int i=1;i<=k;i++)
        {
            scanf("%s%lld",a[i].name,&a[i].v);
        }
        int rk,ac,record[N],r=1;
        int pre_rk=0;            //上一个rk
        memset(record,0,sizeof(record));
        //memset(d,0,sizeof(d));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&d[i].rk,&d[i].ac);
        }
        sort(d+1,d+m+1,cmp1);
        for(int i=1;i<=m;i++)
        {
            //scanf("%d%d",&rk,&ac);   //第rk到,放ac人        被坑了好久,要先排序
            for(int j=pre_rk+1;j<=d[i].rk;j++)
            {
                que.push(a[j]);
            }
            int h;
            for(h=1;h<=d[i].ac;h++)
            {
                if(que.empty())
                    break;
                record[r++]=que.top().come;
                que.pop();
            }
            pre_rk=d[i].rk;
        }
        while(d[m].rk<k)
        {
            d[m].rk++;
            que.push(a[d[m].rk]);
        }
        while(!que.empty())
        {
            record[r++]=que.top().come;
            que.pop();
        }
        int ask[110];
        for(int i=1;i<=q;i++)
        {
            scanf("%d",&ask[i]);
        }
        for(int i=1;i<q;i++)
        {
            printf("%s ",a[record[ask[i]]].name);
        }
        printf("%s\n",a[record[ask[q]]].name);
    }
}

测试数据:
3
3 1 3
a 3
b 2
c 1
1 3
1 2 3
3 2 3
a 3
b 1
c 2
1 3
2 2
1 2 3
3 2 3 //important case
a 0
b 1
c 2
3 2
1 1
1 2 3

output:
a b c
a c b
a c b

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值