hdu 5437Alisha’s Party(优先队列)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4384    Accepted Submission(s): 1120


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value  v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p  people enter her castle. If there are less than  p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n  Please tell Alisha who the  nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,  T  , where  1T15 .

In each test case, the first line contains three numbers  k,m  and  q  separated by blanks.  k  is the number of her friends invited where  1k150,000 . The door would open m times before all Alisha’s friends arrive where  0mk . Alisha will have  q  queries where  1q100 .

The  ith  of the following  k  lines gives a string  Bi , which consists of no more than  200  English characters, and an integer  vi 1vi108 , separated by a blank.  Bi  is the name of the  ith  person coming to Alisha’s party and Bi brings a gift of value  vi .

Each of the following  m  lines contains two integers  t(1tk)  and  p(0pk)  separated by a blank. The door will open right after the  tth  person arrives, and Alisha will let  p  friends enter her castle.

The last line of each test case will contain  q  numbers  n1,...,nq  separated by a space, which means Alisha wants to know who are the  n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing  n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
  
  
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
  
  
Sorey Lailah Rose
 

Source

题意:有n个人拜访,m个操作,q个询问

每个人有个名字和带的礼物的价值,当门外有很多人时,让礼物价值大的排在前面,礼物价值相同时,让先来的人排在前面,没有两个人会同时来,题目给出来的顺序

m个操作,每个操作有个t和p代表是当第t个人来时让p个人进屋子。当最后一个人也来了的时候,所有人都可以直接进屋子。

q个询问,每个询问给出一个编号i,求第i个进屋子的人的名字

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
#define N 150010
struct Node
{
    char name[210];
    int id;
    long long val;
} e[N];
bool operator <(Node a,Node b)
{
    if(a.val==b.val) return a.id>b.id;
    return a.val<b.val;
}
priority_queue<Node>q;
int ans[N];
int main()
{
    int T,t,p;
    int n,m,Q,now,cnt;
    scanf("%d",&T);
    while(T--)
    {
        now=1;
        cnt=1;
        scanf("%d %d %d",&n,&m,&Q);
        for(int i=1; i<=n; i++)
        {
            scanf("%s %lld",e[i].name,&e[i].val);
            e[i].id=i;
        }
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&t,&p);
            for(int i=now; i<=t; i++)
            {
                if(now>n) continue;
                q.push(e[now++]);
            }
            if(now>n)
                while(!q.empty())
                {
                    Node w=q.top();
                    ans[cnt++]=w.id;
                    q.pop();
                }
            else
            {
                for(int i=1; i<=p; i++)
                {
                    if(!q.empty())
                    {
                        Node w=q.top();
                    ans[cnt++]=w.id;
                    q.pop();
                    }
                }
            }
        }
        while(!q.empty())
                {
                    Node w=q.top();
                    ans[cnt++]=w.id;
                    q.pop();
                }
        for(int i=1;i<=Q;i++)
        {
            scanf("%d",&t);
            printf("%s",e[ans[t]].name);
            if(i!=Q) printf(" ");
            else printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值