1146 Topological Order (25分)

测试地址:

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

【题意】

给定一个有向图,判断给定序列是否是拓扑序列

【思路】

用邻接表 v 存储这个有向图,并将每个节点的入度保存在 in 数组中。对每一个要判断是否是拓扑序列的结点遍历,如果当前结点的入度不为 0 则表示不是拓拓扑序列,每次选中某个点后要将它所指向的所有结点的入度 -1,后根据是否出现过入度不为 0 的点决定是否要输出当前的编号 i,temp 是用来判断是否是拓扑序列的

【AC代码】

#include<iostream>
#include<vector>
using namespace std;
int main(){
	int n, m, a, b, k, x, in[1010], flag=0;
	cin >> n >> m;
	vector<int> v[1010];
	for(int i = 0; i < m; i++){
		cin >> a >> b;
		v[a].push_back(b);
		in[b]++;
	}
	cin >> k;
	for(int i = 0; i < k; i++){
		int temp = 1, c[1010];
		for(int j = 1; j <= n; j++){
			c[j] = in[j];
		}
		for(int j = 0; j < n; j++){
			cin >> x;
			if(c[x] != 0) 	temp = 0;
			for(int k = 0; k < v[x].size(); k++){
				c[ v[x][k] ]--;
			}
		}
		if(temp == 1)	continue;
		else{
			if(flag)	cout << " ";
			cout << i;
			flag = 1;	
		}
	}
	return 0;
}
#include <iostream>
#include <vector>
using namespace std;
int main() {
    int n, m, a, b, k, flag = 0, in[1010];
    vector<int> v[1010];
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &a, &b);
        v[a].push_back(b);
        in[b]++;
    }
    scanf("%d", &k);
    for (int i = 0; i < k; i++) {
        int judge = 1;
        vector<int> tin(in, in+n+1);
        for (int j = 0; j < n; j++) {
            scanf("%d", &a);
            if (tin[a] != 0) judge = 0;
            for (int it : v[a]) tin[it]--;
        }
        if (judge == 1) continue;
        printf("%s%d", flag == 1 ? " ": "", i);
        flag = 1;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值