This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
思路:给定一个图,然后给出一系列的图的遍历,问给出的遍历是否是拓扑排序,这个题其实考察的就是拓扑排序的顺序,从入度为0的点开始,那么我们每次判断输入的遍历的是否入度都为0,从第一个数开始,若是0,则与它相连的节点的入度减1,若不是0,则不是拓扑排序,代码如下
#include<iostream>
#include<queue>
using namespace std;
const int maxn = 250010;
const int inf = 0x3fffffff;
int cnt = 1, n, m, a, b, k, w, ans;
int head[maxn], inDegree[maxn], tempInDrgee[maxn], temp[maxn];
struct Node{
int to;
int next;
}node[2 * maxn];
void add(int u, int v) {
node[cnt].to = v;
node[cnt].next = head[u];
head[u] = cnt++;
}
int main() {
cin >> n >> m;
for (int i = 1; i <= m; i++) {
cin >> a >> b;
add(a, b);
inDegree[b]++;
}
cin >> w;
for (int i = 0; i < w; i++) {
for (int z = 1; z <= n; z++) tempInDrgee[z] = inDegree[z];
for (int j = 0; j < n; j++) {
cin >> temp[j];
}
for (int j = 0; j < n; j++) {
a = temp[j];
if (!tempInDrgee[a]) {
for (int k = head[a]; k != 0; k = node[k].next) {
int v = node[k].to;
tempInDrgee[v]--;
}
} else {
if (ans == 0) cout << i;
else cout << " " << i;
ans++;
break;
}
}
}
return 0;
}