1141 PAT Ranking of Institutions (25分)

测试地址:

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: Bstands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

【题意】

给出每个学生的 id、分数、学校,学校名称不区分大小写,输出学校排名、学校名称、总加权成绩、学校参赛人数。学校名称输出时候以小写方式输出。

【思路】

分析:两个map,一个 mp1 用来存储某学校名称对应的参赛人数,另一个 mp2 计算某学校名称对应的总加权成绩。每次学校名称 string school 都要转化为全小写,将 map 中所有学校都保存在 vector v1 中,类型为 num,num 中包括学校姓名、加权总分、参赛人数。对 v1 数组排序,根据题目要求写好 cmp 函数,最后按要求输出。对于排名的处理:设立 pres 表示前一个学校的加权总分,如果 pres 和当前学校的加权总分不同,说明 rank 等于数组下标 +1,否则 rank 不变~

注意:总加权分数取整数部分是要对最后的总和取整数部分,不能每次都直接用 int 存储,不然会有一个3分测试点不通过~

PS:之前直接使用map,导致在新的PAT系统中提交后最后一个测试点超时,改成了unordered_map即可AC

【AC代码】

#include<iostream>
#include<algorithm>
#include<vector>
#include<unordered_map>
using namespace std;
struct num{
	string school;
	int tws, ns;
};
int cmp(num a, num b){
	if(a.tws == b.tws){
		if(a.ns == b.ns)	return a.school < b.school;
		return a.ns < b.ns;
	}
	return a.tws > b.tws;
}
int main(){
	int n;
	cin >> n;
	unordered_map<string, int> mp1;
	unordered_map<string, double> mp2;
	for(int i = 0; i < n; i++){
		string id, school;
		double score;
		cin >> id >> score >> school;
		for(int j = 0; j < school.size(); j++)
			school[j] = tolower(school[j]);
		if(id[0] == 'B')	score = score/1.5;
		else if(id[0] == 'T')	score = score*1.5;
		mp1[school]++;
		mp2[school] += score;
	}
	cout << mp1.size() << endl;
	vector<num> v1;
	for(auto it = mp1.begin(); it != mp1.end(); it++)
		v1.push_back(num{it->first, (int)mp2[it->first], mp1[it->first]});
	sort(v1.begin(), v1.end(), cmp);
	int rank = 0, pres = -1;
	for(int i = 0; i < v1.size(); i++){
		if(pres != v1[i].tws)	rank = i+1;
		pres = v1[i].tws;
		cout << rank << " " << v1[i].school << " " << v1[i].tws << " " << v1[i].ns << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值