32-语言入门-32-Triangular Sums

题目地址: http://acm.nyist.net/JudgeOnline/problem.php?pid=122

描述
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):
X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:
W(n) = SUM[k = 1…n; k * T(k + 1)]
输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210

4 10 2145

英文没咋看懂,重要的是这个公式:

W(n) = SUM[k = 1…n; k * T(k + 1)]

从1开始遍历到输入的n k

k* sum[1-(k+1)]

然后将各个项相加取和

最终输入的格式是:

序号 输入的数值 最终的和

代码:

#include <stdio.h>
static int getSum(int num);
int main()
{
     int readLen = 0;
     scanf("%d",&readLen);
     getchar();
     int index = 1;
     while(readLen > 0)
     {
          int num = 0;
          scanf("%d",&num);
          getchar();
          int sum = getSum(num);
          printf("%d %d %d\n",index,num,sum);
          ++index;
          --readLen;
     }
     return 0;
}
static int getSum(int num)
{
     int index = 1;
     int result = 0;
     int tmpSum = 1;
     for(;index <= num;++index)
     {
          tmpSum += (index+1);
          result += index*tmpSum;
     }
     return result;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值