hdu1195 Open the Lock (bfs)

Open the Lock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6618    Accepted Submission(s): 2979


Problem Description
Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9. 
Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

Now your task is to use minimal steps to open the lock.

Note: The leftmost digit is not the neighbor of the rightmost digit.
 

Input
The input file begins with an integer T, indicating the number of test cases. 

Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
 

Output
For each test case, print the minimal steps in one line.
 

Sample Input
  
  
2 1234 2144 1111 9999
 

Sample Output
  
  
2 4
 

Author
YE, Kai
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1072  1026  1180  1240  1044 
 

Statistic |  Submit |  Discuss |  Note


广搜解决~

对于每个密码进行加、减、交换操作即可。

#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
struct node
{
    int cost;
    char c[10];
    friend bool operator<(node a,node b)
    {
        return a.cost>b.cost;
    }
};
char x_str[10];
char y_str[10];
int bfs()
{
    node node1;
    char ch[10];
    priority_queue<node>s;
    bool vis[18][18][18][18];
    memset(vis,false,sizeof(vis));
    strcpy(node1.c,x_str);
    node1.cost=0;
    s.push(node1);
    while(!s.empty())
    {
        node1=s.top();s.pop();
        if(vis[node1.c[0]-'0'][node1.c[1]-'0'][node1.c[2]-'0'][node1.c[3]-'0']) continue;
        vis[node1.c[0]-'0'][node1.c[1]-'0'][node1.c[2]-'0'][node1.c[3]-'0']=true;
        if(strcmp(node1.c,y_str)==0) return node1.cost;
        for(int i=0;i<4;i++)
        {
            node node2;
            node2.cost=node1.cost+1;
            strcpy(ch,node1.c);
            if(ch[i]=='1')
            {
                //减操作 
                ch[i]='9';
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {
                    strcpy(node2.c,ch);
                    s.push(node2);
                }
                //加操作
                ch[i]='2'; 
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {                    
                      strcpy(node2.c,ch);
                    s.push(node2);
                }
            }
            else if(ch[i]=='9')
            {
                //减操作 
                ch[i]='8';
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {
                    strcpy(node2.c,ch);
                    s.push(node2);
                }
                //加操作
                ch[i]='1'; 
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {
                      strcpy(node2.c,ch);
                       s.push(node2);
                }
            }
            else
            {
                char CH=ch[i];
                //减操作 
                ch[i]=CH-1;
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {
                       strcpy(node2.c,ch);
                    s.push(node2);
                }
                //加操作
                ch[i]=CH+1; 
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {
                      strcpy(node2.c,ch);
                    s.push(node2);
                }
            }
            //i i+1 交换
            if(i<3)
            {
                strcpy(ch,node1.c);
                char CH=ch[i];
                ch[i]=ch[i+1];ch[i+1]=CH;
                if(!vis[ch[0]-'0'][ch[1]-'0'][ch[2]-'0'][ch[3]-'0'])
                {          
                    strcpy(node2.c,ch);
                    s.push(node2);
                }
            }     
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(x_str,0,sizeof(x_str));
        memset(y_str,0,sizeof(y_str));
        scanf("%s %s",x_str,y_str);
        printf("%d\n",bfs());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值