hdu1709 The Balance

Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

Sample Input

3
1 2 4
3
9 2 1

思路

c2[j+k] += c1[j],c2[abs(j-k)] += c1[j];

Sample Output

0
2
4 5

/*************************************************************************
    > File Name: hdu1709.cpp
    > Author:gens_ukiy 
    > Mail: 
    > Created Time: 2016年11月30日 星期三 15时41分25秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<set>
#include<list>
#include<map>
#include<cmath>
using namespace std;
#define rep(i,a,b) for(int i=(a);i<=(b);(i++))
#define inf 0x3f3f3f
#define ll long long
#define maxn 10005
int c1[maxn],c2[maxn];
int main()
{
    int n,a[105],sum;
    while(cin>>n){
        memset(c1,0,sizeof(c1));
        memset(c2,0,sizeof(c2));
        sum=0;
        rep(i,0,n-1)
            scanf("%d",&a[i]),sum+=a[i];
        for(int i=0;i<=a[0];i+=a[0])
            c1[i]=1;
        rep(i,1,n-1)
        {
            rep(j,0,sum)
                for(int k=0;k<=a[i];k+=a[i])
                    c2[j+k]+=c1[j],c2[abs(j-k)]+=c1[j];
            rep(j,0,sum)
                c1[j]=c2[j],c2[j]=0;
        }
        int ans=0,flag[10005];
        rep(i,1,sum)
            if(c1[i]==0)
                flag[ans++]=i;
        printf("%d\n",ans);
        if(ans)
        {
            rep(i,0,ans-2)
                printf("%d ",flag[i]);
            printf("%d\n",flag[ans-1]);
        }
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值