hdu 1709 The Balance

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8118    Accepted Submission(s): 3393


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
 

这道题与常规的凑数字不同,各个数字之间不仅仅是加起来了,相减也是可以的,范围是1到所有数的总和,在这个范围里面求出所有凑不到的数字,只要在原有的基础上,加上一个相减的情况就可以了,就是加上now[abs(k-j)]+=ans[j];



#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int a[11111];
        int a1[111111];
        int a2[111111];
        memset(a1,0,sizeof(a1));
        memset(a2,0,sizeof(a2));
        int sum=0;
        int i,j,k;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        a1[a[1]]=1;
        a1[0]=1;
        for(i=2;i<=n;i++)
        {
            for(j=0;j<=sum;j++)
            {
                for(k=0;k<=a[i];k+=a[i])
                {
                    a2[k+j]+=a1[j];
                    a2[abs(k-j)]+=a1[j];
                }
                
            }
            for(j=0;j<=sum;j++)
            {
                a1[j]=a2[j];
                a2[j]=0;
            }
        }
        int ans[1111];
        int l=0;
        int ans1=0;
        for(i=0;i<=sum;i++)
        {
            if(a1[i]==0)
            {
                ans1++;
                ans[l++]=i;
            }
        }
        if(ans1==0)cout<<"0"<<endl;
        else {    int q=0;
        cout<<ans1<<endl;
        for(i=0;i<l;i++)
        {   
            if(q++)cout<<" ";
            cout<<ans[i];
            }    
            cout<<endl;
        }
    }
    return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值